#50140 [Opn]: With default compilation option, php symbols are unresolved for nsapi sapi
| From: | basantk@php.net | Date: | Tue, 10 Nov 2009 18:48:31 +0000 |
| Subject: | #50140 [Opn]: With default compilation option, php symbols are unresolved for nsapi sapi | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-144421@lists.php.net to get a copy of this message | ||
ID: 50140
Updated by: basantk@php.net
Reported By: basant dot kukreja at gmail dot com
Status: Open
Bug Type: *General Issues
Operating System: Linux
PHP Version: 5.3SVN-2009-11-10 (SVN)
New Comment:
Here is how symbols looks like :
$ nm .libs/libphp5.so | grep php5
004dcfb7 t php5_auth_trans
004dc661 t php5_close
004dc802 t php5_execute
004dc6d4 t php5_init
Symbols are not exported by default.
If we remove
-fvisibility=hidden from compilation options then php compiles
fine and server is able to load libphp5.so correctly.
Previous Comments:
------------------------------------------------------------------------
[2009-11-10 18:46:36] basant dot kukreja at gmail dot com
Description:
------------
On Fedora 11, by default gcc uses
"-fvisibility=hidden", When we compile it for Sun Web Server using
following
configure options, php compiles fine.
'./configure' '--with-nsapi=<server_path>' '--with-zlib'
'--prefix=/usr/local'
But when we start the web server, we get the following error :
failure: CORE2253: Error running Init function load-modules: dlsym for
php5_init failed (<path>/lib/libphp5.so: undefined symbol: php5_init)
failure: server initialization failed
Expected result:
----------------
Server should be able to load php correctly.
Actual result:
--------------
Sun Web Server fails to start because of unexported symbols.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50140&edit=1