#50751 [NEW]: Setting memcache handler by ini_set doesn't work with enabled safe_mode
| From: | kukulich at kukulich dot cz | Date: | Thu, 14 Jan 2010 14:29:31 +0000 |
| Subject: | #50751 [NEW]: Setting memcache handler by ini_set doesn't work with enabled safe_mode | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-146653@lists.php.net to get a copy of this message | ||
From: kukulich at kukulich dot cz
Operating system:
PHP version: 5.3.1
PHP Bug Type: Session related
Bug description: Setting memcache handler by ini_set doesn't work with enabled safe_mode
Description:
------------
Setting memcache handler by ini_set doesn't work with enabled safe_mode.
It works with disabled safe_mode. It also works if handler and save_path
are set in php.ini.
Reproduce code:
---------------
<?php
ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', 'tcp://localhost:11211');
session_start();
Expected result:
----------------
No fatal error
Actual result:
--------------
Warning: ini_set(): Unable to access tcp://localhost:11211 in C:\Program
Files\Apache2\htdocs\bug.php on line 4
Fatal error: session_start(): Failed to initialize storage module:
memcache (path: C:/Program Files/Apache2/temp) in C:\Program
Files\Apache2\htdocs\bug.php on line 6
--
Edit bug report at http://bugs.php.net/?id=50751&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=50751&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=50751&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=50751&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=50751&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=50751&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=50751&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=50751&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=50751&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=50751&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=50751&r=support
Expected behavior: http://bugs.php.net/fix.php?id=50751&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=50751&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=50751&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=50751&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=50751&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=50751&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=50751&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=50751&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=50751&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=50751&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=50751&r=mysqlcfg