#50751 [Opn->Bgs]: Setting memcache handler by ini_set doesn't work with enabled safe_mode
| From: | jani@php.net | Date: | Fri, 15 Jan 2010 08:54:11 +0000 |
| Subject: | #50751 [Opn->Bgs]: Setting memcache handler by ini_set doesn't work with enabled safe_mode | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-146684@lists.php.net to get a copy of this message | ||
ID: 50751
Updated by: jani@php.net
Reported By: kukulich at kukulich dot cz
-Status: Open
+Status: Bogus
Bug Type: Session related
PHP Version: 5.3.1
New Comment:
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions. Due to the volume
of reports we can not explain in detail here why your report is not
a bug. The support channels will be able to provide an explanation
for you.
Thank you for your interest in PHP.
Previous Comments:
------------------------------------------------------------------------
[2010-01-14 14:29:31] kukulich at kukulich dot cz
Description:
------------
Setting memcache handler by ini_set doesn't work with enabled
safe_mode. It works with disabled safe_mode. It also works if handler
and save_path are set in php.ini.
Reproduce code:
---------------
<?php
ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', 'tcp://localhost:11211');
session_start();
Expected result:
----------------
No fatal error
Actual result:
--------------
Warning: ini_set(): Unable to access tcp://localhost:11211 in
C:\Program Files\Apache2\htdocs\bug.php on line 4
Fatal error: session_start(): Failed to initialize storage module:
memcache (path: C:/Program Files/Apache2/temp) in C:\Program
Files\Apache2\htdocs\bug.php on line 6
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50751&edit=1