#50774 [NEW]: libphp5.so: symbol sapi_module: referenced symbol not found
| From: | ivanpank at gmail dot com | Date: | Sat, 16 Jan 2010 00:35:37 +0000 |
| Subject: | #50774 [NEW]: libphp5.so: symbol sapi_module: referenced symbol not found | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-146721@lists.php.net to get a copy of this message | ||
From: ivanpank at gmail dot com
Operating system: solaris 10
PHP version: 5.3.1
PHP Bug Type: Unknown/Other Function
Bug description: libphp5.so: symbol sapi_module: referenced symbol not found
Description:
------------
apache 2.2.14
./configure --prefix=/usr/local/apache2 --enable-so
--enable-modules=all
php 5.3.1
./configure --prefix=/usr/local/php5
--with-config-file-path=/usr/local/apache2/conf --enable-json
--enable-mbstring=all --with-iconv --with-zlib --enable-zip
--enable-sockets --enable-ftp --disable-ipv6 --enable-static
--enable-maintainer-zts --enable-zend-multibyte
--enable-inline-optimization --with-xmlrpc
--with-libxml-dir=/usr/local/libxml2 --enable-soap
--with-curl=/usr/local/curl7 --with-bz2 --enable-sysvmsg --enable-sysvsem
--enable-sysvshm --with-mysql=mysqlnd --with-mysqli=mysqlnd
--with-pdo-mysql=mysqlnd --with-apxs2=/usr/local/apache2/bin/apxs
after apache 2.2.14 make intall an php 5.3.1 make install, there is an
error:
bash-3.00# httpd -k stop
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server: ld.so.1:
httpd: fatal: relocation error: file /usr/local/apache2/modules/libphp5.so:
symbol sapi_module: referenced symbol not found
--
Edit bug report at http://bugs.php.net/?id=50774&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=50774&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=50774&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=50774&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=50774&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=50774&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=50774&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=50774&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=50774&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=50774&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=50774&r=support
Expected behavior: http://bugs.php.net/fix.php?id=50774&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=50774&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=50774&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=50774&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=50774&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=50774&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=50774&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=50774&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=50774&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=50774&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=50774&r=mysqlcfg