Bug #50774 [Com]: libphp5.so: symbol sapi_module: referenced symbol not found
| From: | dbs at nessinc dot com | Date: | Sun, 02 Oct 2011 19:52:05 +0000 |
| Subject: | Bug #50774 [Com]: libphp5.so: symbol sapi_module: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-164032@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=50774&edit=1
ID: 50774
Comment by: dbs at nessinc dot com
Reported by: ivan at myhz dot com
Summary: libphp5.so: symbol sapi_module: referenced symbol
not found
Status: No Feedback
Type: Bug
Package: Compile Failure
Operating System: solaris 10
PHP Version: 5.3.1
Block user comment: N
Private report: N
New Comment:
I had the same trouble. I cleared out /usr/local/php5 (I mean cleared completely out with "cd
/usr/local;rm -rf php5), and redid the configure, make, and make install for php. Then it worked!
Previous Comments:
------------------------------------------------------------------------
[2010-01-28 01:00:01] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2010-01-16 15:10:21] johannes@php.net
Why are you using --enable-maintainer-zts? as the name suggests it's meant to be used by PHP
maintainers. Removing this might fix your issue.
------------------------------------------------------------------------
[2010-01-16 00:43:05] ivan at myhz dot com
there is some similar problems: http://www.google.com/search?hl=en&source=hp&q=libphp5.so%3A+symbol+sapi_module%3A+referenced+symbol+not+found&btnG=Google+Search&aq=f&oq=&aqi=
------------------------------------------------------------------------
[2010-01-16 00:35:37] ivan at myhz dot com
Description:
------------
apache 2.2.14
./configure --prefix=/usr/local/apache2 --enable-so --enable-modules=all
php 5.3.1
./configure --prefix=/usr/local/php5 --with-config-file-path=/usr/local/apache2/conf --enable-json
--enable-mbstring=all --with-iconv --with-zlib --enable-zip --enable-sockets --enable-ftp
--disable-ipv6 --enable-static --enable-maintainer-zts --enable-zend-multibyte
--enable-inline-optimization --with-xmlrpc --with-libxml-dir=/usr/local/libxml2 --enable-soap
--with-curl=/usr/local/curl7 --with-bz2 --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--with-mysql=mysqlnd --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd
--with-apxs2=/usr/local/apache2/bin/apxs
after apache 2.2.14 make intall an php 5.3.1 make install, there is an error:
bash-3.00# httpd -k stop
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load
/usr/local/apache2/modules/libphp5.so into server: ld.so.1: httpd: fatal: relocation error: file
/usr/local/apache2/modules/libphp5.so: symbol sapi_module: referenced symbol not found
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=50774&edit=1