Bug #51242 [NEW]: Empty mysql.default_port does not default to 3306 anymore, but 0
| From: | php-bugs at thequod dot de | Date: | Mon, 08 Mar 2010 23:33:38 +0000 |
| Subject: | Bug #51242 [NEW]: Empty mysql.default_port does not default to 3306 anymore, but 0 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-148411@lists.php.net to get a copy of this message | ||
From:
Operating system:
PHP version: 5.3.2
Package: MySQL related
Bug Type: Bug
Bug description:Empty mysql.default_port does not default to 3306 anymore, but 0
Description:
------------
I've upgraded a server to PHP 5.3.2 (from dotdeb.org), and got "Connection
refused" errors from mysql_connect.
The cause was that I've not specified a port with $host, and PHP used "0"
apparently:
Connection refused (trying to connect via tcp://10.122.42.42:0)
I have âmysql.default_port = â in the ini file, which is the default (I
assume),
and it defaulted to 3306 then previously (5.3.1 from dotdeb), but not
anymore.
--
Edit bug report at http://bugs.php.net/bug.php?id=51242&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=51242&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=51242&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=51242&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=51242&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=51242&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=51242&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=51242&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=51242&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=51242&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=51242&r=support
Expected behavior: http://bugs.php.net/fix.php?id=51242&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=51242&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=51242&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=51242&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=51242&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=51242&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=51242&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=51242&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=51242&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=51242&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=51242&r=mysqlcfg