Bug #51242 [Com]: Empty mysql.default_port does not default to 3306 anymore, but 0

From: Date: Mon, 08 Mar 2010 23:54:48 +0000
Subject: Bug #51242 [Com]: Empty mysql.default_port does not default to 3306 anymore, but 0
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-148413@lists.php.net to get a copy of this message
Edit report at http://bugs.php.net/bug.php?id=51242&edit=1 ID: 51242 Comment by: Reported by: php-bugs at thequod dot de Summary: Empty mysql.default_port does not default to 3306 anymore, but 0 Status: Open Type: Bug Package: MySQL related PHP Version: 5.3.2 New Comment: TML could not reproduce this on ##php: php -d mysql.default_port="" -r '$db = mysql_connect("127.0.0.1") or die(mysql_error()); var_dump($db);' I can (although using another IP). The difference is also that I'm using the Suhosin patch (via dotdeb.org) and TML is not. Previous Comments: ------------------------------------------------------------------------ [2010-03-09 00:33:35] php-bugs at thequod dot de Description: ------------ I've upgraded a server to PHP 5.3.2 (from dotdeb.org), and got "Connection refused" errors from mysql_connect. The cause was that I've not specified a port with $host, and PHP used "0" apparently: Connection refused (trying to connect via tcp://10.122.42.42:0) I have “mysql.default_port = ” in the ini file, which is the default (I assume), and it defaulted to 3306 then previously (5.3.1 from dotdeb), but not anymore. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/bug.php?id=51242&edit=1

« previous php.bugs (#148413) next »