Bug #32330 [Com]: session_destroy, "Failed to initialize storage module", custom session handler
| From: | dave at redterror dot net | Date: | Thu, 15 Jul 2010 19:00:51 +0000 |
| Subject: | Bug #32330 [Com]: session_destroy, "Failed to initialize storage module", custom session handler | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-152448@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=32330&edit=1
ID: 32330
Comment by: dave at redterror dot net
Reported by: mfischer@php.net
Summary: session_destroy, "Failed to initialize storage
module", custom session handler
Status: Closed
Type: Bug
Package: Session related
Operating System: *
PHP Version: 6CVS, 5CVS, 5.2.5, 4CVS (2005-03-17)
New Comment:
Any chance the fix could be backported to 5.2, or I can get a reference
to the fix that was applied? I didn't see this bug number in the
changelog.
I am still seeing the problem on 5.2.12, which was released almost 2
years after the fix was reported to have gone in.
Previous Comments:
------------------------------------------------------------------------
[2008-07-02 10:11:21] jani@php.net
Note: This fix will be in PHP 5.3 and upwards.
------------------------------------------------------------------------
[2008-03-07 23:21:44] gwynne@php.net
This bug has been fixed in CVS.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
------------------------------------------------------------------------
[2008-02-23 06:43:59] fxmulder at gmail dot com
The problem is both mod_data getting set to NULL and
zval_ptr_dtor(&mdata->names[i]); for each of the functions in
ext/session/mod_user.c:PS_CLOSE_FUNC. If the deconstructor calls are
removed as well as the NULL replacements and efree() call on mdata then
it works, except then the containing classes are never deconstructed.
This could possibly be moved to a location when the script is exiting,
and/or another call to session_set_save_handler is made.
------------------------------------------------------------------------
[2008-01-22 05:43:48] gwynne@php.net
This bug still exists in PHP 5.2.5 release and current (as of this
comment) PHP 6CVS. Using a fresh call to session_set_save_handler() does
work, but as previously noted by others, this isn't a desirable
behavior.
------------------------------------------------------------------------
[2007-08-23 05:25:49] jkloske at itee dot uq dot edu dot au
I'm confirming that I'm also affected by this on all OSs and all
versions of PHP I've tried it with (4/5, win/linux)
I'm calling session_write_close() not session_destroy() and it's still
causing the same error. Re-calling session_set_save_handler between
previous close and subsequent open does nothing; the error still
occurs.
This means that phpMyAdmin (which uses multiple sessions for various
authentication handlers at least) is not compatible with user session
handlers, due to this bug :)
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=32330
--
Edit this bug report at http://bugs.php.net/bug.php?id=32330&edit=1