#32330 [Com]: session_destroy, "Failed to initialize storage module", custom session handler
| From: | fteodoro at teatrodetabuas dot com dot br | Date: | Tue, 31 May 2005 07:44:13 +0000 |
| Subject: | #32330 [Com]: session_destroy, "Failed to initialize storage module", custom session handler | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-79750@lists.php.net to get a copy of this message | ||
ID: 32330
Comment by: fteodoro at teatrodetabuas dot com dot br
Reported By: mfischer@php.net
Status: Assigned
Bug Type: Session related
Operating System: *
PHP Version: 5CVS, 4CVS (2005-03-17)
Assigned To: sniper
New Comment:
Is this discussion opened yet?
I think I got a tip in this bug - not the more elegant, but it's
working now.
I was facing the random "failed to initialize storage module" bug. The
bug seems to be related to the physical recording of session data. No
worries on my test server (linux + php 4.2.2 + mysql 3.23.54), but all
the worries on the web server (php 4.3.11 + mysql 4.0.22).
Since I have no access to the commercial server unless ftp, I achieved
the trick with a simple .access file, with a simple couple of
handlers:
php_value session.save_handler files
php_value session.save_path /home/domain/htdocs/temp
and I haven't received error messages for some days.
Too dummy? Hope it works...
Previous Comments:
------------------------------------------------------------------------
[2005-05-21 19:19:42] rasmus@php.net
I think you are on the right track mfischer. It looks like PS(mod) and
PS(mod_data) can get out of synch which would cause this. And I think
all the others with seemingly unrelated issues are actually related.
If PS(mod_data) leaks out of the per-request sandbox and infects
subsequent requests all it takes is one application on a server to use
its own session handler and it could affect other seemingly trivial
standalone session apps on that server.
------------------------------------------------------------------------
[2005-05-19 14:09:55] lekhoi at lekhoi dot com dot au
I use
Window XP -- running Apache
SQLite version 2.8.14
PHP version 5.0.4
and am experiencing the same problem of PHP reporting error when
calling session_start()
I have never have this problem before.
However, I am using SQLiteManager ver 1.0.6 and during the development
stage I came across this problem. This problem occurs quite randomly
specially when I try to modify the database structure or have troubled
sql statement. It feels and sounds like a memory leak problem with
SQLite functions. I have to stress that I come across this only when
using SQLiteManager.
I have used and configured session using SQLite as the database for
sessions storing and never have a problem.
To fix this, I restart Apache, and it works everytime.
------------------------------------------------------------------------
[2005-05-17 21:01:39] semorales at segob dot gob dot mx
Any notice about this bug? I'm thinking about using the handler but I'm
afraid it will crash my server. Please let me know.
------------------------------------------------------------------------
[2005-04-30 11:31:53] dmih at in-solve dot ru
I've added several notes as this bug (marked as bogus):
http://bugs.php.net/bug.php?id=32897
Please consider them, as it seems that it is about this bug really.
Thanks.
------------------------------------------------------------------------
[2005-04-19 07:37:14] labsy at seznam dot org
Since this bug is non-persistent, it is very hard to reproduce.
Now, since I run PHP 5.0.2 as ISAPI module, I did a change and added
php5isapi.dll also as ISAPI FILTER under web site properties in IIS.
I don't have a slight idea what would that change, but it seems to
solve problem - I hope.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/32330
--
Edit this bug report at http://bugs.php.net/?id=32330&edit=1