Bug #18583: odbc_connect() fails with Oracle 8.1.7 after 4.2.2 upgrade
| From: | wittend at wwrinc dot com | Date: | Fri, 26 Jul 2002 03:01:20 +0000 |
| Subject: | Bug #18583: odbc_connect() fails with Oracle 8.1.7 after 4.2.2 upgrade | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-15260@lists.php.net to get a copy of this message | ||
From: wittend@wwrinc.com
Operating system: Win2k
PHP version: 4.2.2
PHP Bug Type: ODBC related
Bug description: odbc_connect() fails with Oracle 8.1.7 after 4.2.2 upgrade
All calls to odbc_connect() fails after upgrading from PHP 4.2.1 to 4.2.2.
PHP is running under Apache 2.0.39 (not IIS) as sapi. This occurs with
both MS's and Oracle's ODBC drivers. DSNs set up for this purpose work
fine when executed with the MS ODBCTe32.exe tool and MS Access. The PHP
works when directed to non-Oracle DSNs and when transferred to another
system set up similarly but using 4.2.1. ODBC traces, Oracle traces, and
the php error logs all point to an authentication failure (perhaps related
to wide/multibyte string conversion to ANSI ??).
PHP-error.log:
SQL error: [Oracle][ODBC][Ora]ORA-12640: Authentication adapter
initialization failed
Oracle sqlnet.log:
***********************************************************************
Fatal NI connect error 12640, connecting to:
(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=nt1)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=PRODOFA.world)(CID=(PROGRAM=H:\www\apache-2.0.39\apache2\bin\Apache.exe)(HOST=NT1)(USER=SYSTEM))))
VERSION INFORMATION:
TNS for 32-bit Windows: Version 8.1.7.0.0 - Production
Windows NT TCP/IP NT Protocol Adapter for 32-bit Windows: Version
8.1.7.0.0 - Production
Time: 25-JUL-2002 18:00:22
Tracing not turned on.
Tns error struct:
nr err code: 0
ns main err code: 12640
TNS-12640: Authentication adapter initialization failed
ns secondary err code: 0
nt main err code: 0
nt secondary err code: 0
nt OS err code: 0
Thanks.
--
Edit bug report at http://bugs.php.net/?id=18583&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=18583&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=18583&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=18583&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=18583&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=18583&r=support
Expected behavior: http://bugs.php.net/fix.php?id=18583&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=18583&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=18583&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=18583&r=globals