#18583 [Fbk->Bgs]: odbc_connect() fails with Oracle 8.1.7 after 4.2.2 upgrade
| From: | kalowsky@php.net | Date: | Wed, 04 Sep 2002 05:22:30 +0000 |
| Subject: | #18583 [Fbk->Bgs]: odbc_connect() fails with Oracle 8.1.7 after 4.2.2 upgrade | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18382@lists.php.net to get a copy of this message | ||
ID: 18583
Updated by: kalowsky@php.net
Reported By: wittend@wwrinc.com
-Status: Feedback
+Status: Bogus
Bug Type: ODBC related
Operating System: Win2k
PHP Version: 4.2.2
Previous Comments:
------------------------------------------------------------------------
[2002-07-26 00:01:39] kalowsky@php.net
There is literally no code difference between 4.2.1 and 4.2.2 in ODBC.
The only code change was done the way POST variables are handled and
thats it.
Are you sure this isn't an error on your end?
------------------------------------------------------------------------
[2002-07-25 23:01:19] wittend@wwrinc.com
All calls to odbc_connect() fails after upgrading from PHP 4.2.1 to
4.2.2. PHP is running under Apache 2.0.39 (not IIS) as sapi. This
occurs with both MS's and Oracle's ODBC drivers. DSNs set up for this
purpose work fine when executed with the MS ODBCTe32.exe tool and MS
Access. The PHP works when directed to non-Oracle DSNs and when
transferred to another system set up similarly but using 4.2.1. ODBC
traces, Oracle traces, and the php error logs all point to an
authentication failure (perhaps related to wide/multibyte string
conversion to ANSI ??).
PHP-error.log:
SQL error: [Oracle][ODBC][Ora]ORA-12640: Authentication adapter
initialization failed
Oracle sqlnet.log:
***********************************************************************
Fatal NI connect error 12640, connecting to:
(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=nt1)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=PRODOFA.world)(CID=(PROGRAM=H:\www\apache-2.0.39\apache2\bin\Apache.exe)(HOST=NT1)(USER=SYSTEM))))
VERSION INFORMATION:
TNS for 32-bit Windows: Version 8.1.7.0.0 - Production
Windows NT TCP/IP NT Protocol Adapter for 32-bit Windows: Version
8.1.7.0.0 - Production
Time: 25-JUL-2002 18:00:22
Tracing not turned on.
Tns error struct:
nr err code: 0
ns main err code: 12640
TNS-12640: Authentication adapter initialization failed
ns secondary err code: 0
nt main err code: 0
nt secondary err code: 0
nt OS err code: 0
Thanks.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=18583&edit=1