Bug #52805 [NEW]: Unable to load dynamic library php_ldap.dll
| From: | emiller at gomedico dot com | Date: | Thu, 09 Sep 2010 19:55:07 +0000 |
| Subject: | Bug #52805 [NEW]: Unable to load dynamic library php_ldap.dll | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-154218@lists.php.net to get a copy of this message | ||
From:
Operating system: Windows 2003 Server
PHP version: 5.2.14
Package: LDAP related
Bug Type: Bug
Bug description:Unable to load dynamic library php_ldap.dll
Description:
------------
System Config:
Windows Server 2003 (32-bit)
Apache 2.2.16
PHP 5.2.14
Error Message in Apache Log:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Program
Files\\PHP\\5.2\\ext\\php_ldap.dll' - The operating system cannot run
%1.\r\n in
Unknown on line 0
Facts / Things I've Tried
- Apache LDAP module is showing in PHPINFO to indicate that it is loading
correctly and issue resides on PHP side.
- php_ldap extension uncommented.
- C:\Program Files\PHP\5.2 and C:\Program Files\PHP\5.2\ext have both been
added
to the PATH variable
- extension_dir set to C:\Program Files\PHP\5.2\ext
- dll location has been verified manually (by two sets of eyes)
- Apache has been rebooted
- Server has been rebooted
- Downloaded PHP 5.2.14 (VC6 Thread-Safe for Win) from php.net, replaced
DLL
with DLL from ZIP and rebooted.
- Replaced entire install of PHP with ZIP listed above, rebooted.
- Placed DLLs in System32 folder (out of desperation)
Test script:
---------------
n/a
Expected result:
----------------
PHP LDAP module to load correctly and show in PHPInfo
Actual result:
--------------
Error Message in Apache Log:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Program
Files\\PHP\\5.2\\ext\\php_ldap.dll' - The operating system cannot run
%1.\r\n in
Unknown on line 0
--
Edit bug report at http://bugs.php.net/bug.php?id=52805&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=52805&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=52805&r=trysnapshot53
Try a snapshot (trunk): http://bugs.php.net/fix.php?id=52805&r=trysnapshottrunk
Fixed in SVN: http://bugs.php.net/fix.php?id=52805&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=52805&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=52805&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=52805&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=52805&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=52805&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=52805&r=support
Expected behavior: http://bugs.php.net/fix.php?id=52805&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=52805&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=52805&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=52805&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=52805&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=52805&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=52805&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=52805&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=52805&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=52805&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=52805&r=mysqlcfg