Bug #52805 [Com]: Unable to load dynamic library php_ldap.dll
Edit report at http://bugs.php.net/bug.php?id=52805&edit=1
ID: 52805
Comment by: emiller at gomedico dot com
Reported by: emiller at gomedico dot com
Summary: Unable to load dynamic library php_ldap.dll
Status: Bogus
Type: Bug
Package: LDAP related
Operating System: Windows 2003 Server
PHP Version: 5.2.14
Block user comment: N
New Comment:
Thats the conflict Im having, it may show as loaded but within PHPInfo
it is not
showing as loaded.
Previous Comments:
------------------------------------------------------------------------
[2010-09-09 23:01:02] pajoye@php.net
That means the module has been loaded already (aka it works).
See:
php -m
to see the list of loaded modules.
and
php -i | find "php.ini"
to see the php.ini used, the one where php_ldap.dll is defined.
Please ask more questions/support on the PHP Windows or PHP setup
mailing lists, see the 'list' link in the php.net site.
------------------------------------------------------------------------
[2010-09-09 22:33:01] emiller at gomedico dot com
php.exe -d extension=php_ldap.dll returns PHP Warning: Module 'ldap'
already
loaded in Unknown on line 0
------------------------------------------------------------------------
[2010-09-09 22:24:28] pajoye@php.net
Works just fine (since years in 5.2), please try in CLI (php.exe -d ...
) to see the exact error.
------------------------------------------------------------------------
[2010-09-09 21:55:06] emiller at gomedico dot com
Description:
------------
System Config:
Windows Server 2003 (32-bit)
Apache 2.2.16
PHP 5.2.14
Error Message in Apache Log:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Program
Files\\PHP\\5.2\\ext\\php_ldap.dll' - The operating system cannot run
%1.\r\n in
Unknown on line 0
Facts / Things I've Tried
- Apache LDAP module is showing in PHPINFO to indicate that it is
loading
correctly and issue resides on PHP side.
- php_ldap extension uncommented.
- C:\Program Files\PHP\5.2 and C:\Program Files\PHP\5.2\ext have both
been added
to the PATH variable
- extension_dir set to C:\Program Files\PHP\5.2\ext
- dll location has been verified manually (by two sets of eyes)
- Apache has been rebooted
- Server has been rebooted
- Downloaded PHP 5.2.14 (VC6 Thread-Safe for Win) from php.net, replaced
DLL
with DLL from ZIP and rebooted.
- Replaced entire install of PHP with ZIP listed above, rebooted.
- Placed DLLs in System32 folder (out of desperation)
Test script:
---------------
n/a
Expected result:
----------------
PHP LDAP module to load correctly and show in PHPInfo
Actual result:
--------------
Error Message in Apache Log:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Program
Files\\PHP\\5.2\\ext\\php_ldap.dll' - The operating system cannot run
%1.\r\n in
Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=52805&edit=1
Thread (6 messages)