#18615 [NEW]: --with-apxs fails with Stronghold 3 and wrongly suggests --with-apxs2
| From: | thought at phenomind dot com | Date: | Sun, 28 Jul 2002 21:35:36 +0000 |
| Subject: | #18615 [NEW]: --with-apxs fails with Stronghold 3 and wrongly suggests --with-apxs2 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-15448@lists.php.net to get a copy of this message | ||
From: thought@phenomind.com
Operating system: Linux 7.2
PHP version: 4.2.2
PHP Bug Type: Dynamic loading
Bug description: --with-apxs fails with Stronghold 3 and wrongly suggests --with-apxs2
Installing php4.2.2 on two identically configured Linux 7.2 servers. Both
php compilations crash at the same point with same error.
Configuration line is:
./configure --with-apxs=/usr/local/apachestronghold/bin/apxs
--with-oci=/usr/local/oracle/OraHome1
configure program crashes saying:
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... configure:
error: Use --with-apxs2 with Apache 2.x!
--
Stronghold 3 definitely running Apache 1.3.22 see http://212.137.27.66/
If I use --with-apxs2 like it suggests, which I know is wrong, the
installation fails when running make (not a surprise)
--
Edit bug report at http://bugs.php.net/?id=18615&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=18615&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=18615&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=18615&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=18615&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=18615&r=support
Expected behavior: http://bugs.php.net/fix.php?id=18615&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=18615&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=18615&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=18615&r=globals