#18615 [Opn->Csd]: --with-apxs fails with Stronghold 3 and wrongly suggests --with-apxs2

From: Date: Sun, 28 Jul 2002 21:39:19 +0000
Subject: #18615 [Opn->Csd]: --with-apxs fails with Stronghold 3 and wrongly suggests --with-apxs2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15449@lists.php.net to get a copy of this message
ID: 18615 Updated by: sniper@php.net Reported By: thought@phenomind.com -Status: Open +Status: Closed Bug Type: Dynamic loading Operating System: Linux 7.2 PHP Version: 4.2.2 New Comment: This bug has been fixed in CVS. You can grab a snapshot of the CVS version at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites. Thank you for the report, and for helping us make PHP better. Previous Comments: ------------------------------------------------------------------------ [2002-07-28 17:35:35] thought@phenomind.com Installing php4.2.2 on two identically configured Linux 7.2 servers. Both php compilations crash at the same point with same error. Configuration line is: ./configure --with-apxs=/usr/local/apachestronghold/bin/apxs --with-oci=/usr/local/oracle/OraHome1 configure program crashes saying: Configuring SAPI modules checking for AOLserver support... no checking for Apache 1.x module support via DSO through APXS... configure: error: Use --with-apxs2 with Apache 2.x! -- Stronghold 3 definitely running Apache 1.3.22 see http://212.137.27.66/ If I use --with-apxs2 like it suggests, which I know is wrong, the installation fails when running make (not a surprise) ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18615&edit=1

« previous php.bugs (#15449) next »