#17549 [Com]: Apahe 2.0.36 fails to start: "unresolved symbol"

From: Date: Tue, 30 Jul 2002 01:21:15 +0000
Subject: #17549 [Com]: Apahe 2.0.36 fails to start: "unresolved symbol"
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15537@lists.php.net to get a copy of this message
ID: 17549 Comment by: ghall@NOSPAM.csh.rit.edu Reported By: mcaplin@miami.edu Status: Open Bug Type: Apache2 related Operating System: Compaq Tru64UNIX 5.1A PHP Version: 4.2.1 New Comment: the only way i have figured around this bug is to use the portable threading library (pth). Previous Comments: ------------------------------------------------------------------------ [2002-07-10 06:33:53] dgm300@ecs.soton.ac.uk I'm experiencing the same problem. The symbol "__pthread_self" unresolved error message. I'm running Apache 2.0.39 and php 4.2.1 with a similar configuration as above (without the --quiet option). ------------------------------------------------------------------------ [2002-06-01 09:31:23] sniper@php.net reclassified ------------------------------------------------------------------------ [2002-05-31 17:46:48] mcaplin@miami.edu I configured php 4.2.1 as a dynamic module for Apache 2.0.36 (./configure --with-apxs2=/usr/local/apache/bin/apxs --quiet) and proceeded to make and make install without problems. After adding the proper entries to httpd.conf, I tried to start Apache and got: # /usr/local/apache/bin/apachectl start Syntax error on line 230 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/libphp4.so into server: dlopen: /usr/local/apache/modules/libphp4.so: symbol "__pthread_self" unresolved /usr/local/apache/bin/apachectl start: httpd could not be started Exit 3 Here's some info from httpd: # /usr/local/apache/bin/httpd -V Server version: Apache/2.0.36 Server built: May 31 2002 14:29:30 Server's Module Magic Number: 20020329:1 Architecture: 64-bit Server compiled with.... -D APACHE_MPM_DIR="server/mpm/prefork" -D APR_HAS_MMAP -D APR_HAVE_IPV6 -D APR_USE_SYSVSEM_SERIALIZE -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT -D APR_HAS_OTHER_CHILD -D AP_HAVE_RELIABLE_PIPED_LOGS -D HTTPD_ROOT="/usr/local/apache" -D SUEXEC_BIN="/usr/local/apache/bin/suexec" -D DEFAULT_ERRORLOG="logs/error_log" -D SERVER_CONFIG_FILE="conf/httpd.conf" # /usr/local/apache/bin/httpd -l Compiled in modules: core.c mod_access.c mod_auth.c mod_include.c mod_log_config.c mod_env.c mod_setenvif.c prefork.c http_core.c mod_mime.c mod_autoindex.c mod_asis.c mod_cgi.c mod_negotiation.c mod_dir.c mod_actions.c mod_userdir.c mod_alias.c mod_so.c ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17549&edit=1

« previous php.bugs (#15537) next »