Bug #17549: Apahe 2.0.36 fails to start: "unresolved symbol"
| From: | mcaplin at miami dot edu | Date: | Fri, 31 May 2002 21:46:49 +0000 |
| Subject: | Bug #17549: Apahe 2.0.36 fails to start: "unresolved symbol" | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-9021@lists.php.net to get a copy of this message | ||
From: mcaplin@miami.edu
Operating system: Compaq Tru64UNIX 5.1A
PHP version: 4.2.1
PHP Bug Type: Dynamic loading
Bug description: Apahe 2.0.36 fails to start: "unresolved symbol"
I configured php 4.2.1 as a dynamic module for Apache 2.0.36 (./configure
--with-apxs2=/usr/local/apache/bin/apxs --quiet) and proceeded to make and
make install without problems.
After adding the proper entries to httpd.conf, I tried to start Apache and
got:
# /usr/local/apache/bin/apachectl start
Syntax error on line 230 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: dlopen:
/usr/local/apache/modules/libphp4.so: symbol "__pthread_self" unresolved
/usr/local/apache/bin/apachectl start: httpd could not be started
Exit 3
Here's some info from httpd:
# /usr/local/apache/bin/httpd -V
Server version: Apache/2.0.36
Server built: May 31 2002 14:29:30
Server's Module Magic Number: 20020329:1
Architecture: 64-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_MMAP
-D APR_HAVE_IPV6
-D APR_USE_SYSVSEM_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/usr/local/apache"
-D SUEXEC_BIN="/usr/local/apache/bin/suexec"
-D DEFAULT_ERRORLOG="logs/error_log"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
# /usr/local/apache/bin/httpd -l
Compiled in modules:
core.c
mod_access.c
mod_auth.c
mod_include.c
mod_log_config.c
mod_env.c
mod_setenvif.c
prefork.c
http_core.c
mod_mime.c
mod_autoindex.c
mod_asis.c
mod_cgi.c
mod_negotiation.c
mod_dir.c
mod_actions.c
mod_userdir.c
mod_alias.c
mod_so.c
--
Edit bug report at http://bugs.php.net/?id=17549&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=17549&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=17549&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=17549&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=17549&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=17549&r=support
Expected behavior: http://bugs.php.net/fix.php?id=17549&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=17549&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=17549&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=17549&r=globals