#16826 [Fbk->Csd]: __floatdidf: symbol not found when attempting to load module in apache

From: Date: Wed, 31 Jul 2002 22:33:35 +0000
Subject: #16826 [Fbk->Csd]: __floatdidf: symbol not found when attempting to load module in apache
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15728@lists.php.net to get a copy of this message
 ID:               16826
 Updated by:       sniper@php.net
 Reported By:      veg@fatsquirrel.org
-Status:           Feedback
+Status:           Closed
 Bug Type:         InterBase related
 Operating System: Solaris 8
 PHP Version:      4.2.0
 New Comment:

This is now 'fixed' in CVS. To fix it in 4.2.x, just add
--enable-libgcc to your configure line.




Previous Comments:
------------------------------------------------------------------------

[2002-07-31 11:09:59] php@fsckit.net

I get the identical bug with 4.2.2 on Solaris 8 with 
Apache 1.3.26 although I'm not using interbase. I'm seeing 
this with --with-curl support enabled instead. libcurl is 
version 7.9.8

./configure  --with-mysql --with-curl 
--with-apxs=/usr/local/apache/bin/apxs

4.2.2 worked previously without curl support. I did a make 
clean, re-ran configure, installed and an apachectl 
configtest results in:

/usr/local/apache/bin/apachectl configtest
Syntax error on line 208 of 
/usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into 
server: ld.so.1: /usr/local/apache/bin/httpd: fatal: 
relocation error: file /usr/local/lib/libcurl.so.2: symbol 
__floatdidf: referenced symbol not found

Compiling with --enable-libgcc works.

------------------------------------------------------------------------

[2002-04-25 21:47:57] sniper@php.net

Does it work without --with-interbase ?
(btw. You can also use --enable-libgcc to add it)


------------------------------------------------------------------------

[2002-04-25 11:10:45] veg@fatsquirrel.org

4.2.0 on solaris 8 with apache 1.3.24.
Configured with:
./configure --with-apxs=/usr/local/apache/bin/apxs
--with-mysql=/usr/local/mysql --with-interbase

Builds fine. When attempting to start apache I get the following
error:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol __floatdidf: referenced
symbol not found

Adding the following onto the final build line:
-L/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/ -lgcc

produces a build that seems to work ok.
Thanks in advance.

------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=16826&edit=1



Thread (6 messages)

« previous php.bugs (#15728) next »