#16826 [Com]: __floatdidf: symbol not found when attempting to load module in apache
ID: 16826
Comment by: guido dot gavilanes at sungemini dot com dot co
Reported By: veg at fatsquirrel dot org
Status: Closed
Bug Type: InterBase related
Operating System: Solaris 8
PHP Version: 4.2.0
New Comment:
Had the same problem in Solaris 8, when installing php-4.3.3 with curl
7.10.4 and apache 1.3.22 (+ ssl patch), so I configured another
installation for curl with the additional parameters:
LDFLAGS="$LDFLAGS -L/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.0/
-lgcc"
Then I compiled again php, et voilá! the problem was solved, thank you
for all your help!
Previous Comments:
------------------------------------------------------------------------
[2002-11-24 02:37:24] nospam at 1111-internet dot com
I ran into this same problem trying to build curl 7.10.2 into php 4.2.3
on Solaris 9, and the solutions suggested here didn't correct the
problem. After some research and experimentation, it appears that the
real source of this problem is an issue with gcc (3.2) during the
original curl build, as opposed to it being a problem with php. Adding
LDFLAGS="$LDFLAGS -L/usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.2
-lgcc"
to the curl configuration in order for curl to find and connect to
__floatdidf in libgcc.a corrected the problem for me.
This is a frustrating one, as it sneaks through your curl build and
your entire php build without any indication that something may be
wrong, only to show up and thwart your very last step - your
webserver's startup!
------------------------------------------------------------------------
[2002-07-31 18:33:35] sniper@php.net
This is now 'fixed' in CVS. To fix it in 4.2.x, just add
--enable-libgcc to your configure line.
------------------------------------------------------------------------
[2002-07-31 11:09:59] php at fsckit dot net
I get the identical bug with 4.2.2 on Solaris 8 with
Apache 1.3.26 although I'm not using interbase. I'm seeing
this with --with-curl support enabled instead. libcurl is
version 7.9.8
./configure --with-mysql --with-curl
--with-apxs=/usr/local/apache/bin/apxs
4.2.2 worked previously without curl support. I did a make
clean, re-ran configure, installed and an apachectl
configtest results in:
/usr/local/apache/bin/apachectl configtest
Syntax error on line 208 of
/usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into
server: ld.so.1: /usr/local/apache/bin/httpd: fatal:
relocation error: file /usr/local/lib/libcurl.so.2: symbol
__floatdidf: referenced symbol not found
Compiling with --enable-libgcc works.
------------------------------------------------------------------------
[2002-04-25 21:47:57] sniper@php.net
Does it work without --with-interbase ?
(btw. You can also use --enable-libgcc to add it)
------------------------------------------------------------------------
[2002-04-25 11:10:45] veg at fatsquirrel dot org
4.2.0 on solaris 8 with apache 1.3.24.
Configured with:
./configure --with-apxs=/usr/local/apache/bin/apxs
--with-mysql=/usr/local/mysql --with-interbase
Builds fine. When attempting to start apache I get the following
error:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol __floatdidf: referenced
symbol not found
Adding the following onto the final build line:
-L/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/ -lgcc
produces a build that seems to work ok.
Thanks in advance.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16826&edit=1
Thread (6 messages)