Bug #54278 [NEW]: mysqli extension compiles against mysql-5.5.9 but does not run

From: Date: Wed, 16 Mar 2011 18:10:06 +0000
Subject: Bug #54278 [NEW]: mysqli extension compiles against mysql-5.5.9 but does not run
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-159527@lists.php.net to get a copy of this message
From:             
Operating system: Linux
PHP version:      Irrelevant
Package:          Reproducible crash
Bug Type:         Bug
Bug description:mysqli extension compiles against mysql-5.5.9 but does not run

Description:
------------
PHP-5.1.6 mysqli extension compiles against mysql-5.5.9 but fails to load.
The failure message is: 

PHP Warning:  PHP Startup: Unable to load dynamic library
'/usr/lib64/php/modules/mysqli.so' - /usr/lib64/php/modules/mysqli.so:
undefined symbol: mysql_disable_reads_from_master in Unknown on line 0

The reason for this is that the msql_disable_ functions were removed from
mysql, as per the following bug: http://bugs.mysql.com/bug.php?id=31952

Please update such that php-5.1.6 is compatible with mysql-5.5
Thanks!


-- 
Edit bug report at http://bugs.php.net/bug.php?id=54278&edit=1
-- 
Try a snapshot (PHP 5.2):            http://bugs.php.net/fix.php?id=54278&r=trysnapshot52
Try a snapshot (PHP 5.3):            http://bugs.php.net/fix.php?id=54278&r=trysnapshot53
Try a snapshot (trunk):              http://bugs.php.net/fix.php?id=54278&r=trysnapshottrunk
Fixed in SVN:                        http://bugs.php.net/fix.php?id=54278&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=54278&r=needdocs
Fixed in release:                    http://bugs.php.net/fix.php?id=54278&r=alreadyfixed
Need backtrace:                      http://bugs.php.net/fix.php?id=54278&r=needtrace
Need Reproduce Script:               http://bugs.php.net/fix.php?id=54278&r=needscript
Try newer version:                   http://bugs.php.net/fix.php?id=54278&r=oldversion
Not developer issue:                 http://bugs.php.net/fix.php?id=54278&r=support
Expected behavior:                   http://bugs.php.net/fix.php?id=54278&r=notwrong
Not enough info:                     http://bugs.php.net/fix.php?id=54278&r=notenoughinfo
Submitted twice:                     http://bugs.php.net/fix.php?id=54278&r=submittedtwice
register_globals:                    http://bugs.php.net/fix.php?id=54278&r=globals
PHP 4 support discontinued:          http://bugs.php.net/fix.php?id=54278&r=php4
Daylight Savings:                    http://bugs.php.net/fix.php?id=54278&r=dst
IIS Stability:                       http://bugs.php.net/fix.php?id=54278&r=isapi
Install GNU Sed:                     http://bugs.php.net/fix.php?id=54278&r=gnused
Floating point limitations:          http://bugs.php.net/fix.php?id=54278&r=float
No Zend Extensions:                  http://bugs.php.net/fix.php?id=54278&r=nozend
MySQL Configuration Error:           http://bugs.php.net/fix.php?id=54278&r=mysqlcfg



Thread (2 messages)

« previous php.bugs (#159527) next »