Bug #54278 [Opn->Bgs]: mysqli extension compiles against mysql-5.5.9 but does not run
| From: | johannes@php.net | Date: | Wed, 16 Mar 2011 18:14:47 +0000 |
| Subject: | Bug #54278 [Opn->Bgs]: mysqli extension compiles against mysql-5.5.9 but does not run | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-159528@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=54278&edit=1
ID: 54278
Updated by: johannes@php.net
Reported by: michael at nileguide dot com
Summary: mysqli extension compiles against mysql-5.5.9 but
does not run
-Status: Open
+Status: Bogus
Type: Bug
Package: Reproducible crash
Operating System: Linux
PHP Version: Irrelevant
Block user comment: N
Private report: N
New Comment:
This feature was removed with PHP 5.3.0. PHP 5.1 is not supported
anymore for a loooong time.
Previous Comments:
------------------------------------------------------------------------
[2011-03-16 19:10:05] michael at nileguide dot com
Description:
------------
PHP-5.1.6 mysqli extension compiles against mysql-5.5.9 but fails to
load. The failure message is:
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib64/php/modules/mysqli.so' - /usr/lib64/php/modules/mysqli.so:
undefined symbol: mysql_disable_reads_from_master in Unknown on line 0
The reason for this is that the msql_disable_ functions were removed
from mysql, as per the following bug:
http://bugs.mysql.com/bug.php?id=31952
Please update such that php-5.1.6 is compatible with mysql-5.5
Thanks!
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=54278&edit=1