#18795 [NEW]: open_basedir does not work correctly

From: Date: Wed, 07 Aug 2002 21:10:53 +0000
Subject: #18795 [NEW]: open_basedir does not work correctly
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-16217@lists.php.net to get a copy of this message
From: ilia@prohost.org Operating system: Linux 2.4.19 PHP version: 4CVS-2002-08-07 PHP Bug Type: Scripting Engine problem Bug description: open_basedir does not work correctly open_basedir directive does not allow operation within directories owned by another users. php.ini directives: safe_mode on open_basedir = /home/ilia/ /home/ilia/ is owned by ilia:ilia test.php ( owned by ilia:ilia, run as root ) <?php mkdir('safe_mode1', 0755); mkdir('safe_mode1/safe_mode2', 0755); ?> creation of safe_mode1 directory succeeds, however creation of 'safe_mode2' inside 'safe_mode1' fails with a safe_mode error about uids not matching. Shouldn't open_basedir directive allow creation of files/directories anywhere above /home/ilia/ ? -- Edit bug report at http://bugs.php.net/?id=18795&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=18795&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=18795&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=18795&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=18795&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=18795&r=support Expected behavior: http://bugs.php.net/fix.php?id=18795&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=18795&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=18795&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=18795&r=globals

« previous php.bugs (#16217) next »