#18795 [Opn->Bgs]: open_basedir does not work correctly

From: Date: Wed, 07 Aug 2002 21:39:18 +0000
Subject: #18795 [Opn->Bgs]: open_basedir does not work correctly
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-16219@lists.php.net to get a copy of this message
ID: 18795 Updated by: edink@php.net Reported By: ilia@prohost.org -Status: Open +Status: Bogus Bug Type: Scripting Engine problem Operating System: Linux 2.4.19 PHP Version: 4CVS-2002-08-07 New Comment: No since open_basedir is independent of safe_mode. It is safe_mode which prevents opening files with different uid. Previous Comments: ------------------------------------------------------------------------ [2002-08-07 17:10:53] ilia@prohost.org open_basedir directive does not allow operation within directories owned by another users. php.ini directives: safe_mode on open_basedir = /home/ilia/ /home/ilia/ is owned by ilia:ilia test.php ( owned by ilia:ilia, run as root ) <?php mkdir('safe_mode1', 0755); mkdir('safe_mode1/safe_mode2', 0755); ?> creation of safe_mode1 directory succeeds, however creation of 'safe_mode2' inside 'safe_mode1' fails with a safe_mode error about uids not matching. Shouldn't open_basedir directive allow creation of files/directories anywhere above /home/ilia/ ? ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18795&edit=1

« previous php.bugs (#16219) next »