#13595 [Com]: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on

From: Date: Fri, 09 Aug 2002 18:24:33 +0000
Subject: #13595 [Com]: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-16400@lists.php.net to get a copy of this message
ID: 13595 Comment by: kasper@303.nu Reported By: plafundum@yahoo.com Status: Closed Bug Type: Session related Operating System: Debian Sid PHP Version: 4.0.6 New Comment: I'm also using debian sid, and the same happens. PHP 4.2.1, nothing in /tmp. The first time it happened I removed php4, and re-installed it, and the problem was gone. And when it occured 15 minutes ago I tried removing php4-cgi, which I also had installed, and the problem is gone now. So there might be a kind of clash between php4 and php4-cgi? But anyway, it would be very nice to have a more descriptive output from php4... Previous Comments: ------------------------------------------------------------------------ [2002-07-30 22:49:50] jal@jal.org So, following this thread, I'm still not having any luck. I'm running debian-woodie, and upgraded to the 4.2.1 package for it. I checked my php.ini for weird paths, checked /tmp and (because someone mentioned it) /etc for session_mm files, and the problem still persists. Here's what I get out of strace: open("/usr/lib/apache/1.3/libphp4.so", O_RDONLY) = 4 [...] open("/usr/lib/libmm.so.11", O_RDONLY) = 4 [...] open("./php.ini", O_RDONLY|O_LARGEFILE) = 5 getcwd("/etc/php4/apache", 4096) = 17 lstat("/etc/php4/apache/php.ini", {st_mode=S_IFREG|0644, st_size=26777, ...}) = 0 open("/etc/ld.so.cache", O_RDONLY) = 5 open("/lib/libnss_db.so.2", O_RDONLY) = 5 open("/lib/libnss_files.so.2", O_RDONLY) = 5 open("/usr/lib/libdb3.so.3", O_RDONLY) = 5 open("/var/lib/misc/protocols.db", O_RDWR|O_LARGEFILE) = -1 ENOENT (No such file or directory) open("/var/lib/misc/protocols.db", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory) open("/etc/protocols", O_RDONLY) = 5 open("/var/lib/misc/protocols.db", O_RDWR|O_LARGEFILE) = -1 ENOENT (No such file or directory) open("/var/lib/misc/protocols.db", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory) open("/etc/protocols", O_RDONLY) = 5 unlink("/tmp/session_mm_apache0.sem") = -1 ENOENT (No such file or directory) I left in some cruft, because I have no idea what's going on. If anyone has any thoughts... -j ------------------------------------------------------------------------ [2002-06-18 09:19:23] plafundum@yahoo.com Hi y'all, This 'bug' is solved long time ago. 1 Upgrade to php 4.2.1 2 see /tmp for a session_mm.sem and remove it. ------------------------------------------------------------------------ [2002-06-18 04:00:23] derick@php.net This is most likely fixed in the latest version. Please reopen if PHP 4.2.1 doesn't fix the problem. ------------------------------------------------------------------------ [2002-06-12 22:15:51] supers@starblaze.2y.net I get fstat64(3, {st_mode=S_IFREG|0644, st_size=1748, ...}) = 0 unlink("/tmp/session_mm_apache0.sem") = -1 ENOENT (No such file or directory) before it dies, any idea? (using debian linux) ------------------------------------------------------------------------ [2002-04-24 17:18:41] 2002@gabrielwicke.de Sorry, i forgot to mention my settings: session handler is 'files', location for those /tmp- my php.ini is completely unchanged from the defaults sessionwise. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/13595 -- Edit this bug report at http://bugs.php.net/?id=13595&edit=1

« previous php.bugs (#16400) next »