Req #60199 [PATCH]: php-fpm does not log an error for "too many open files"
| From: | fat@php.net | Date: | Wed, 02 Nov 2011 13:39:04 +0000 |
| Subject: | Req #60199 [PATCH]: php-fpm does not log an error for "too many open files" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-164809@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=60199&edit=1
ID: 60199
Patch added by: fat@php.net
Reported by: julien at palard dot fr
Summary: php-fpm does not log an error for "too many open
files"
Status: Assigned
Type: Feature/Change Request
Package: FPM related
Operating System: All
PHP Version: Irrelevant
Assigned To: fat
Block user comment: N
Private report: N
New Comment:
The following patch has been added/updated:
Patch Name: fpm-bug60199.patch
Revision: 1320241144
URL: https://bugs.php.net/patch-display.php?bug=60199&patch=fpm-bug60199.patch&revision=1320241144
Previous Comments:
------------------------------------------------------------------------
[2011-11-02 08:56:18] julien at palard dot fr
Description:
------------
When php-fpm hits a "too many open files", it returns a 404 and don't log anything,
so typically for people using nginx they got a "No input file specified." that is hard to
debug.
I dropped an strace here :
http://pastebin.com/PVCqF9cD
I think that php-fpm should log something to let people diagnose why they open so much file and/or
modify their rlimit.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=60199&edit=1