Req #60199 [Fbk->Csd]: enhance FPM error log when the primary script can't be open
| From: | fat@php.net | Date: | Tue, 15 Nov 2011 22:30:46 +0000 |
| Subject: | Req #60199 [Fbk->Csd]: enhance FPM error log when the primary script can't be open | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-165198@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=60199&edit=1
ID: 60199
Updated by: fat@php.net
Reported by: julien at palard dot fr
-Summary: php-fpm does not log an error for "too many open
files"
+Summary: enhance FPM error log when the primary script can't
be open
-Status: Feedback
+Status: Closed
Type: Feature/Change Request
Package: FPM related
Operating System: All
PHP Version: Irrelevant
Assigned To: fat
Block user comment: N
Private report: N
New Comment:
This bug has been fixed in SVN.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
For Windows:
http://windows.php.net/snapshots/
Thank you for the report, and for helping us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2011-11-15 22:29:50] fat@php.net
Automatic comment from SVN on behalf of fat
Revision: http://svn.php.net/viewvc/?view=revision&revision=319281
Log: - FR #60199 (enhance FPM error log when the primary script can't be open)
------------------------------------------------------------------------
[2011-11-02 13:40:13] fat@php.net
Can you please test the attached patch and confirm it fixes your problem.
Then reopen the bug.
++ Jerome
------------------------------------------------------------------------
[2011-11-02 13:39:04] fat@php.net
The following patch has been added/updated:
Patch Name: fpm-bug60199.patch
Revision: 1320241144
URL: https://bugs.php.net/patch-display.php?bug=60199&patch=fpm-bug60199.patch&revision=1320241144
------------------------------------------------------------------------
[2011-11-02 08:56:18] julien at palard dot fr
Description:
------------
When php-fpm hits a "too many open files", it returns a 404 and don't log anything,
so typically for people using nginx they got a "No input file specified." that is hard to
debug.
I dropped an strace here :
http://pastebin.com/PVCqF9cD
I think that php-fpm should log something to let people diagnose why they open so much file and/or
modify their rlimit.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=60199&edit=1