Bug #54716 [Opn->Fbk]: Internal Server Error when php compiled with oci driver

From: Date: Mon, 07 Nov 2011 22:24:58 +0000
Subject: Bug #54716 [Opn->Fbk]: Internal Server Error when php compiled with oci driver
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-164941@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=54716&edit=1

 ID:                 54716
 Updated by:         sixd@php.net
 Reported by:        dominik dot szybowski at bzwbk dot pl
 Summary:            Internal Server Error when php compiled with oci
                     driver
-Status:             Open
+Status:             Feedback
 Type:               Bug
 Package:            OCI8 related
 Operating System:   AIX
 PHP Version:        5.2.17
 Block user comment: N
 Private report:     N

 New Comment:

Please provide more details, including the complete build steps and a script that 
causes the error


Previous Comments:
------------------------------------------------------------------------
[2011-05-12 10:53:03] dominik dot szybowski at bzwbk dot pl

Description:
------------
Apache server throws internal server error during sso kerberos authentication when php is compiled
with parameter --with-oci8=instantclient,/usr/local/instantclient_11_1/lib

We have currently working apache 2.2.17 server with php 5.2.17 (other versions was also tested)
configured with mit kerberos 5.1.6 and mod_auth_kerb5.4 kerberos module. Before we try to add oci
connection to oracle everything works fine and users was authenticated by sso. After we recompiled
php with oci our apache instance can't load kerberos configuration file and throws internal
server error. It can be related to issue with subprocesses http://bugs.php.net/bug.php?id=9013 

I already tried oracle support but they didn't like to help with php.

Expected result:
----------------
Error log without oci (works fine):

[Wed May 11 16:39:54 2011] [debug] src/mod_auth_kerb.c(1628): [client host] kerb_authenticate_user
entered with user (NULL) and auth_type Kerberos, referer: https://host/altair/views/show_docclasses.php
[Wed May 11 16:39:54 2011] [debug] src/mod_auth_kerb.c(1240): [client host] Acquiring creds for
HTTP/host@domain, referer: https://10.151.67.126/altair/views/show_docclasses.php
[Wed May 11 16:39:54 2011] [debug] src/mod_auth_kerb.c(1385): [client host] Verifying client data
using KRB5 GSS-API with our SPNEGO lib, referer: https://host/altair/views/show_docclasses.php
[Wed May 11 16:39:54 2011] [debug] src/mod_auth_kerb.c(1401): [client host] Client didn't
delegate us their credential, referer: https://10.151.67.126/altair/views/show_docclasses.php
[Wed May 11 16:39:54 2011] [debug] src/mod_auth_kerb.c(1420): [client host] GSS-API token of length
161 bytes will be sent back, referer:

Actual result:
--------------
Error log with oci:

[Fri May 06 17:25:38 2011] [debug] src/mod_auth_kerb.c(1628): [client 10.150.203.118]
kerb_authenticate_user entered with user (NULL) and auth_type Kerberos
[Fri May 06 17:25:38 2011] [debug] src/mod_auth_kerb.c(1101): [client 10.150.203.118] GSS-API
major_status:000d0000, minor_status:96c73a87
[Fri May 06 17:25:38 2011] [error] [client 10.150.203.118] gss_import_name() failed: Miscellaneous
failure (, Can't open/find Kerberos configuration file)




------------------------------------------------------------------------



-- 
Edit this bug report at https://bugs.php.net/bug.php?id=54716&edit=1


Thread (9 messages)

« previous php.bugs (#164941) next »