Bug #54716 [Com]: Internal Server Error when php compiled with oci driver
Edit report at https://bugs.php.net/bug.php?id=54716&edit=1
ID: 54716
Comment by: rattlebrain at gmx dot net
Reported by: dominik dot szybowski at bzwbk dot pl
Summary: Internal Server Error when php compiled with oci
driver
Status: No Feedback
Type: Bug
Package: OCI8 related
Operating System: AIX
PHP Version: 5.2.17
Block user comment: N
Private report: N
New Comment:
dfwin: what is the difference compared to your earlier post?
My problem is not that I can't make mod_auth_kerb and the PHP OCI8 extension work at the same
time, but that this combination breaks reloads of Apache. I added also an explanation what probably
causes this behaviour. Restarts work fine, so as a work-around, I replaced all reloads by
restarts...
Previous Comments:
------------------------------------------------------------------------
[2014-01-15 08:47:15] dfwin at live dot de
Here is what helped me:
I configured PHP with
--with-oci8=shared,/data/oracle
and added the oci8.so in php.ini
For example:
extension_dir="/usr/local/src/php-5.2.17/modules"
extension=oci8.so
After this steps, my oci8 and mod_auth_kerb are working fine.
------------------------------------------------------------------------
[2014-01-10 14:06:03] dfwin at live dot de
I am facing the same problems like the others.
# Environment:
- RHEL Server 6.5
- PHP 5.2.17 (old applications ...) (tested PHP 5.3.28 also, same problem)
- Apache 2.2.25
- mod_auth_kerb 5.4
- Oracle 11.2.0.1.0
# PHP build with
./configure --prefix=/usr/local/php5 \
--with-libdir=lib64 \
--with-apxs2=/usr/local/apache2/bin/apxs \
--with-libxml-dir \
--enable-wddx \
--with-oci8=/data/oracle \
--with-gd \
--with-png-dir \
--with-zlib-dir \
--with-jpeg-dir \
--with-freetype-dir \
--with-curl \
--with-ldap \
--enable-exif \
--enable-mbstring \
--with-pspell \
--enable-soap
As soon as you compile PHP with the oci8 extensions, mod_auth_kerb & apache crash with:
[debug] src/mod_auth_kerb.c(1101): [client xx.xx.xx.xx] GSS-API major_status:000d0000,
minor_status:96c73a87
[error] [client xx.xx.xx.xx] gss_acquire_cred() failed: Unspecified GSS failure. Minor code may
provide more information ()
PHP Applications that use oci8, are working fine, but you can't use SSO.
Without oci8 extensions kerb/sso is working.
------------------------------------------------------------------------
[2013-02-18 00:34:50] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
------------------------------------------------------------------------
[2012-10-18 21:34:13] debian at linux dot org
In our case the PDO Oracle driver break kerberos config.
No need to use it, the bug appears when reloading Apache if the PDO Oracle driver is "ON".
Just disabled it.
------------------------------------------------------------------------
[2012-08-24 06:44:48] debian at linux dot org
My Configuration :
- Debian GNU/Linux 6 64-bit
- Oracle Instantclient 11.2
- PHP 5.3.14
- mod_auth_kerb 5.4
- Apache 2.2.16
- Kerberos Heimdal
This can be reproduced using Apache graceful command.
Just after the mod_auth_kerb will fail to read the kerberos conf
gss_import_name() failed: Miscellaneous failure (, Can't open/find Kerberos configuration file.
it will use the same default kerberos configuration as Oracle Database !!!
You can force the path using sqlnet.ora but it will fail after when using gss acquire credential
(unknown error 2 or 21).
We did not find a fix.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=54716
--
Edit this bug report at https://bugs.php.net/bug.php?id=54716&edit=1
Thread (9 messages)