Bug #61120 [NEW]: FPM/FastCGI fails to construct file location
From:
Operating system: Linux 3.x
PHP version: 5.3.10
Package: FPM related
Bug Type: Bug
Bug description:FPM/FastCGI fails to construct file location
Description:
------------
System: openSUSE 12.1, php 5.3.8
Using mod_proxy_fcgi from apache 2.3.16, an Apache server is configured to
contact php-fpm and/or php-cgi for PHP files. On opening
http://localhost/index.php [which maps to
/srv/www/htdocs/index.php in the
filesystem], proxy_fcgi constructs a request (see attachment) and forwards
it to fpm. fpm responds with error 404, despite the file being in
existence.
fpm seems to ignore DOCUMENT_ROOT.
Expected result:
----------------
Execute the file /srv/www/htdocs/index.php.
Actual result:
--------------
fpm returns a HTTP 404 error. (The same occurs when using php-cgi -b
instead of php-fpm.)
--
Edit bug report at https://bugs.php.net/bug.php?id=61120&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=61120&r=trysnapshot54
Try a snapshot (PHP 5.3): https://bugs.php.net/fix.php?id=61120&r=trysnapshot53
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=61120&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=61120&r=fixed
Fixed in SVN and need be documented: https://bugs.php.net/fix.php?id=61120&r=needdocs
Fixed in release: https://bugs.php.net/fix.php?id=61120&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=61120&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=61120&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=61120&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=61120&r=support
Expected behavior: https://bugs.php.net/fix.php?id=61120&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=61120&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=61120&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=61120&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=61120&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=61120&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=61120&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=61120&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=61120&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=61120&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=61120&r=mysqlcfg
Thread (2 messages)
- psimms at tomenserv dot dyndns dot org