Bug #61120 [Opn->Csd]: FPM/FastCGI fails to construct file location
Edit report at https://bugs.php.net/bug.php?id=61120&edit=1
ID: 61120
User updated by: psimms at tomenserv dot dyndns dot org
Reported by: psimms at tomenserv dot dyndns dot org
Summary: FPM/FastCGI fails to construct file location
-Status: Open
+Status: Closed
Type: Bug
Package: FPM related
Operating System: Linux 3.x
PHP Version: 5.3.10
Block user comment: N
Private report: N
New Comment:
Close as not-a-bug. Apparently one is supposed to make apache put the document root into
SCRIPT_FILENAME. Oh well, good to know.
Previous Comments:
------------------------------------------------------------------------
[2012-02-17 10:09:06] psimms at tomenserv dot dyndns dot org
Description:
------------
System: openSUSE 12.1, php 5.3.8
Using mod_proxy_fcgi from apache 2.3.16, an Apache server is configured to contact php-fpm and/or
php-cgi for PHP files. On opening http://localhost/index.php [which maps to
/srv/www/htdocs/index.php in the filesystem], proxy_fcgi constructs a request (see attachment) and
forwards it to fpm. fpm responds with error 404, despite the file being in existence.
fpm seems to ignore DOCUMENT_ROOT.
Expected result:
----------------
Execute the file /srv/www/htdocs/index.php.
Actual result:
--------------
fpm returns a HTTP 404 error. (The same occurs when using php-cgi -b instead of php-fpm.)
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=61120&edit=1
Thread (2 messages)