Bug #21260 [NoF]: phpBB fails to work with GD turned on

From: Date: Tue, 15 May 2012 10:05:26 +0000
Subject: Bug #21260 [NoF]: phpBB fails to work with GD turned on
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-170451@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=21260&edit=1 ID: 21260 User updated by: cmsaspopup at mail dot ru Reported by: cmsaspopup at mail dot ru Summary: phpBB fails to work with GD turned on Status: No Feedback Type: Bug -Package: GD related +Package: *General Issues Operating System: Linux PHP Version: 4.3.0 Block user comment: N Private report: N New Comment: Всем привет! Если вы хотите собственный рекламный бизнес в сети Интернет, тогда вам будет интересна эта статья! В начале 2007 года началась разработка скрипта рекламного сервиса PopUp v1.0, компанией Minatrix. В то время это был самый пик подобной рекламы. Сам скрипт был очень простой и имел минимальный набор функций, но не смотря на это, стал лидирующим продуктом в рекламном бизнесе. С того времени, велись постоянные доработки и внедрения новых видов рекламы, прошёл множество стадий тестирования. Были учтины все пожелания клиентов и в итоге получился мощнейший скрипт в данном направлении. На данный момент с гордостью можем сообщить, что на данный момент - это самый функциональный, не имеющий уязвимостей, хорошо защищён от взломов и накруток, постоянно-обновляемый продукт. Стоимость скрипта в соотношении: качество/цена поражают многих, тем более, что мы всегда идём на встречу клиента и предлогаем гибкие условия покупки в рассрочку. Вложенные средства в скрипт быстро и легко окупаются! Всё зависит только от ваших возможностей, желания и стратегии развития! В продаже появилась новая версия скрипта рекламного сервиса: CMS AdminStation + PopUp v4.0 pro. Сейчас уже сложно назвать этот скрипт PopUp, т.к. в нём уже 9 популярных в сети видов рекламы, а именно: 1. PopUp - реклама 2. Баннерная реклама 3. Контекстная реклама 4. Тизерная реклама 5. BodyClick (ClickUnder) 6. Peel-down (уголок) 7. Плавающий блок ссылок 8. Расстяжка (Top-line) 9. ICQ-window 10. SLIDER Более подробно вы можете узнать на сайте: http://adminstation.ru/?ref=613 Previous Comments: ------------------------------------------------------------------------ [2003-01-13 18:18:54] sniper@php.net No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. ------------------------------------------------------------------------ [2002-12-28 22:35:24] pollita@php.net Please run the following test on your system: 1) Create a file named "testgd.php" in the document root of your webserver with the following content: <?php $img = imagecreate(100,100); $black = imagecolorallocate($img,0,0,0); $white = imagecolorallocate($img,255,255,255); imagefilledrectangle($img,0,0,99,99,$white); imagerectangle($img,0,0,99,99,$black); header("Content-type: image/png"); imagePNG($img); ?> 2) Browse the URL for that page (i.e.: http://myserver.com/testgd.php ) 3) Tell us if a white square with a black frame appears. If the image shows properly then the problem is likely with PHPBB and there's nothing anyone here can do. If not, then there may be a problem with your GD build. ------------------------------------------------------------------------ [2002-12-28 21:56:17] cmsaspopup at mail dot ru I use PHPbb on my web site(I have also already reported this problem to them) when I install PHP without the new GD support in 4.3.0 turned on everything works fine, however if I turn the GD support on the PHPbb fails to load and all I get is a blank page...no errors no anything.... The following are my configure lines.... PHPbb works.... ./configure --with-mysql=/mysql --with-apxs PHPbb doesn't work... ./configure --with-mysql=/mysql --with-apxs --with-gd --with-zlib-dir=/usr/include I should mention that I also use phpMyAdmin...and that works fine either way.... ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=21260&edit=1

« previous php.bugs (#170451) next »