#21260 [Fbk->NoF]: phpBB fails to work with GD turned on

From: Date: Tue, 14 Jan 2003 00:18:55 +0000
Subject: #21260 [Fbk->NoF]: phpBB fails to work with GD turned on
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-29948@lists.php.net to get a copy of this message
ID: 21260 Updated by: sniper@php.net Reported By: haplo@epithna.com -Status: Feedback +Status: No Feedback Bug Type: GD related Operating System: Linux PHP Version: 4.3.0 New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. Previous Comments: ------------------------------------------------------------------------ [2002-12-28 22:35:24] pollita@php.net Please run the following test on your system: 1) Create a file named "testgd.php" in the document root of your webserver with the following content: <?php $img = imagecreate(100,100); $black = imagecolorallocate($img,0,0,0); $white = imagecolorallocate($img,255,255,255); imagefilledrectangle($img,0,0,99,99,$white); imagerectangle($img,0,0,99,99,$black); header("Content-type: image/png"); imagePNG($img); ?> 2) Browse the URL for that page (i.e.: http://myserver.com/testgd.php ) 3) Tell us if a white square with a black frame appears. If the image shows properly then the problem is likely with PHPBB and there's nothing anyone here can do. If not, then there may be a problem with your GD build. ------------------------------------------------------------------------ [2002-12-28 21:56:17] haplo@epithna.com I use PHPbb on my web site(I have also already reported this problem to them) when I install PHP without the new GD support in 4.3.0 turned on everything works fine, however if I turn the GD support on the PHPbb fails to load and all I get is a blank page...no errors no anything.... The following are my configure lines.... PHPbb works.... ./configure --with-mysql=/mysql --with-apxs PHPbb doesn't work... ./configure --with-mysql=/mysql --with-apxs --with-gd --with-zlib-dir=/usr/include I should mention that I also use phpMyAdmin...and that works fine either way.... ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21260&edit=1

« previous php.bugs (#29948) next »