#18948 [NEW]: Apache fails to start, ssl cert error?
| From: | shena at darklock dot com | Date: | Fri, 16 Aug 2002 20:43:21 +0000 |
| Subject: | #18948 [NEW]: Apache fails to start, ssl cert error? | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-17052@lists.php.net to get a copy of this message | ||
From: shena@darklock.com
Operating system: Cobalt RAQ3i
PHP version: 4.2.2
PHP Bug Type: Apache related
Bug description: Apache fails to start, ssl cert error?
When compiling php 4.2.2 with the lines:
./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/sbin/apxs
--enable-versioning --with-gettext --enable-safe-mode --with-openssl
--with-ttf --with-zlib --enable-debugger --enable-ftp --with-xml
--enable-inline-optimization --with-bz2 --with-dom --with-gdbm
--with-regex=system --enable-magic-quotes --enable-sockets
--enable-track-vars
doing a make, make install etc, on apache 1.3.6 I get this error from
apache when trying to start it:
Setting up Web Service: Site home has invalid certificate: 4999
ssl_cant_files_missing /usr/sbin/httpd
Then, apache fails to start.
If I remove the module from httpd.conf and restart apache, it works fine,
although I still get the error.
If I recompile php without gettext it will work fine with apache.
--
Edit bug report at http://bugs.php.net/?id=18948&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=18948&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=18948&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=18948&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=18948&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=18948&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=18948&r=support
Expected behavior: http://bugs.php.net/fix.php?id=18948&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=18948&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=18948&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=18948&r=globals