#18948 [Bgs->Opn]: Apache fails to start, ssl cert error?
| From: | shena at darklock dot com | Date: | Fri, 16 Aug 2002 22:06:42 +0000 |
| Subject: | #18948 [Bgs->Opn]: Apache fails to start, ssl cert error? | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-17055@lists.php.net to get a copy of this message | ||
ID: 18948
User updated by: shena@darklock.com
Reported By: shena@darklock.com
-Status: Bogus
+Status: Open
Bug Type: Apache related
Operating System: Cobalt RAQ3i
PHP Version: 4.2.2
New Comment:
Man? ;)
It may be an SSL/Apache/PHP interaction error. I actually managed to
still get the error even when I took out "gettext". I had to completely
disable OpenSSL and compile PHP without SSL in order to run apache+php
together. (sigh)
Previous Comments:
------------------------------------------------------------------------
[2002-08-16 17:27:28] tal@php.net
It seems like an apache bug. If you can prove it's not, re-open the
report and give us some proof, young man!
-Tal
------------------------------------------------------------------------
[2002-08-16 16:43:20] shena@darklock.com
When compiling php 4.2.2 with the lines:
./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/sbin/apxs
--enable-versioning --with-gettext --enable-safe-mode --with-openssl
--with-ttf --with-zlib --enable-debugger --enable-ftp --with-xml
--enable-inline-optimization --with-bz2 --with-dom --with-gdbm
--with-regex=system --enable-magic-quotes --enable-sockets
--enable-track-vars
doing a make, make install etc, on apache 1.3.6 I get this error from
apache when trying to start it:
Setting up Web Service: Site home has invalid certificate: 4999
ssl_cant_files_missing /usr/sbin/httpd
Then, apache fails to start.
If I remove the module from httpd.conf and restart apache, it works
fine, although I still get the error.
If I recompile php without gettext it will work fine with apache.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=18948&edit=1