Bug #62197 [NEW]: Starting Apache failed
| From: | thierry dot tisserand at lu dot nomura dot com | Date: | Thu, 31 May 2012 10:42:26 +0000 |
| Subject: | Bug #62197 [NEW]: Starting Apache failed | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-170949@lists.php.net to get a copy of this message | ||
From: thierry dot tisserand at lu dot nomura dot com
Operating system: AIX 7100-01-02-1150 (64 bits)
PHP version: 5.3.13
Package: Apache related
Bug Type: Bug
Bug description:Starting Apache failed
Description:
------------
Apache 2.4.2 and php-5.3.13-1.aix5.1 has been installed with RPM
(http://www.perzl.org/aix)
Apache only ("Include conf/extra/httpd-php.conf" has been comment in the
f)ile httpd.conf) start without error.
If I try to start Apache wtih php, I had an error:
Test script:
---------------
/opt/freeware/sbin/apachectl -k start
Actual result:
--------------
httpd: Syntax error on line 513 of /opt/freeware/etc/httpd/conf/httpd.conf:
Syntax error on line 6 of
/opt/freeware/etc/httpd/conf/extra/httpd-php.conf: Cannot load
/opt/freeware/lib/httpd/modules/libphp5.so into server: rtld: 0712-001
Symbol ap_log_error was referenced\n from module
/opt/freeware/lib/httpd/modules/libphp5.so(), but a runtime definition\n\t
of the symbol was not found.\nrtld: 0712-001 Symbol ap_log_rerror was
referenced\n from module /opt/freeware/lib/httpd/modules/libphp5.so(),
but a runtime definition\n\t of the symbol was not found.\nrtld:
0712-001 Symbol ap_get_server_version was referenced\n from module
/opt/freeware/lib/httpd/modules/libphp5.so(), but a runtime definition\n\t
of the symbol was not found.\nrtld: 0712-001 Symbol unixd_config was
referenced\n from module /opt/freeware/lib/httpd/modules/libphp5.so(),
but a runtime definition\n\t of the symbol was not found.
--
Edit bug report at https://bugs.php.net/bug.php?id=62197&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=62197&r=trysnapshot54
Try a snapshot (PHP 5.3): https://bugs.php.net/fix.php?id=62197&r=trysnapshot53
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=62197&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=62197&r=fixed
Fixed in SVN and need be documented: https://bugs.php.net/fix.php?id=62197&r=needdocs
Fixed in release: https://bugs.php.net/fix.php?id=62197&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=62197&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=62197&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=62197&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=62197&r=support
Expected behavior: https://bugs.php.net/fix.php?id=62197&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=62197&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=62197&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=62197&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=62197&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=62197&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=62197&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=62197&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=62197&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=62197&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=62197&r=mysqlcfg