Bug #62197 [Nab]: Starting Apache failed

From: Date: Thu, 07 Jun 2012 08:56:28 +0000
Subject: Bug #62197 [Nab]: Starting Apache failed
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-171097@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=62197&edit=1

 ID:                 62197
 User updated by:    thierry dot tisserand at lu dot nomura dot com
 Reported by:        thierry dot tisserand at lu dot nomura dot com
 Summary:            Starting Apache failed
 Status:             Not a bug
 Type:               Bug
 Package:            Apache related
 Operating System:   AIX 7100-01-02-1150 (64 bits)
 PHP Version:        5.3.13
 Block user comment: N
 Private report:     N

 New Comment:

Thank you for your answer.

I'm going to contact the package manager.


Previous Comments:
------------------------------------------------------------------------
[2012-06-04 23:46:20] johannes@php.net

We don't provide those packages. Wehave no control over them.

------------------------------------------------------------------------
[2012-06-03 01:46:24] omg00dness at yahoo dot com

Have you taken steps to contact the package manager?  Have you posted on forums/mailing lists for
your operating system or package manager?  What makes you sure this is a PHP <Bug> and not
user error or the package?  Have you installed from source?

I consider the bug reporting system to be more for bugs than a troubleshooting forum.  That's
why I'm asking all those questions, since not many people may be able to replicate your setup. 
The error seems to be pretty straight forward and you appear to be missing modules.  That may be
from the packager.

------------------------------------------------------------------------
[2012-06-01 07:21:28] thierry dot tisserand at lu dot nomura dot com

httpd-2.2.21 and (php-5.3.8 ou php-5.3.13) OK

httpd-2.4.2 and (php-5.3.8 ou php-5.3.13) KO, => rtld: 0712-001 Symbol ap_log_error was
referenced

------------------------------------------------------------------------
[2012-05-31 10:42:26] thierry dot tisserand at lu dot nomura dot com

Description:
------------
Apache 2.4.2 and php-5.3.13-1.aix5.1  has been installed with RPM (http://www.perzl.org/aix)

Apache only ("Include conf/extra/httpd-php.conf" has been comment in the f)ile httpd.conf)
start without error.

If I try to start Apache wtih php, I had an error:

Test script:
---------------
/opt/freeware/sbin/apachectl -k start


Actual result:
--------------
httpd: Syntax error on line 513 of /opt/freeware/etc/httpd/conf/httpd.conf: Syntax error on line 6
of /opt/freeware/etc/httpd/conf/extra/httpd-php.conf: Cannot load
/opt/freeware/lib/httpd/modules/libphp5.so into server: rtld: 0712-001 Symbol ap_log_error was
referenced\n      from module /opt/freeware/lib/httpd/modules/libphp5.so(), but a runtime
definition\n\t    of the symbol was not found.\nrtld: 0712-001 Symbol ap_log_rerror was referenced\n
     from module /opt/freeware/lib/httpd/modules/libphp5.so(), but a runtime definition\n\t    of
the symbol was not found.\nrtld: 0712-001 Symbol ap_get_server_version was referenced\n      from
module /opt/freeware/lib/httpd/modules/libphp5.so(), but a runtime definition\n\t    of the symbol
was not found.\nrtld: 0712-001 Symbol unixd_config was referenced\n      from module
/opt/freeware/lib/httpd/modules/libphp5.so(), but a runtime definition\n\t    of the symbol was not
found.


------------------------------------------------------------------------



-- 
Edit this bug report at https://bugs.php.net/bug.php?id=62197&edit=1


Thread (6 messages)

« previous php.bugs (#171097) next »