#18997 [Opn->Fbk]: cannot load libphp4.so - referenced symbol not found

From: Date: Tue, 20 Aug 2002 20:55:59 +0000
Subject: #18997 [Opn->Fbk]: cannot load libphp4.so - referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17348@lists.php.net to get a copy of this message
ID: 18997 Updated by: rasmus@php.net Reported By: LouPicciano@comcast.net -Status: Open +Status: Feedback Bug Type: Dynamic loading Operating System: Solaris 9 SPARC PHP Version: 4.2.2 New Comment: Try adding --enable-libgcc to your PHP configure line. Let us know if that fixes it. Previous Comments: ------------------------------------------------------------------------ [2002-08-20 16:54:30] LouPicciano@comcast.net After a new compile of php 4.2.2 with _only_ the '--with-apxs=/dir/path' option: '# apachectl configtest' reports: Syntax error in httpd.conf: Cannot load /usr/apache/libexec/libphp4.so into server: ld.so.1: /usr/apache/hin/httpd: fatal: relocation error: file /usr/apache/libexec/libphp4.so: symbol __cmpdi2: referenced symbol not found. '# nm /usr/apache/libexec/libphp4.so | grep cmpd' reports: [5171] | 0| 0|NOTY |GLOB |0 |UNDEF |__cmpdi2 Help! (Thanks in advance...) ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18997&edit=1

« previous php.bugs (#17348) next »