#18997 [Fbk->Opn]: cannot load libphp4.so - referenced symbol not found

From: Date: Wed, 21 Aug 2002 19:07:43 +0000
Subject: #18997 [Fbk->Opn]: cannot load libphp4.so - referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17472@lists.php.net to get a copy of this message
ID: 18997 User updated by: LouPicciano@comcast.net Reported By: LouPicciano@comcast.net -Status: Feedback +Status: Open Bug Type: Dynamic loading Operating System: Solaris 9 SPARC PHP Version: 4.2.2 New Comment: adding --enable-libgcc _alone_ did not work, however... ./configure --with-apxs=/usr/apache/bin/apxs --enable-libgcc --enable-track-vars --with-mysql=/usr/local/mysql got us beyond the __cmpdi2 symbol error. Now are getting: Cannot load <...>/libphp4.so into server: ld.so.1: /usr/apache/bin/httpd: fatal: relocation error: file <...>/libphp4.so: symbol uncompress: referenced symbol not found Also, an interesting sidenote: path to mysql must (apparently) be a 'real' pathname. Configure does not follow symlinks... Previous Comments: ------------------------------------------------------------------------ [2002-08-20 16:55:59] rasmus@php.net Try adding --enable-libgcc to your PHP configure line. Let us know if that fixes it. ------------------------------------------------------------------------ [2002-08-20 16:54:30] LouPicciano@comcast.net After a new compile of php 4.2.2 with _only_ the '--with-apxs=/dir/path' option: '# apachectl configtest' reports: Syntax error in httpd.conf: Cannot load /usr/apache/libexec/libphp4.so into server: ld.so.1: /usr/apache/hin/httpd: fatal: relocation error: file /usr/apache/libexec/libphp4.so: symbol __cmpdi2: referenced symbol not found. '# nm /usr/apache/libexec/libphp4.so | grep cmpd' reports: [5171] | 0| 0|NOTY |GLOB |0 |UNDEF |__cmpdi2 Help! (Thanks in advance...) ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18997&edit=1

« previous php.bugs (#17472) next »