#19019 [NEW]: exec doesnt accept abs paths

From: Date: Wed, 21 Aug 2002 13:41:20 +0000
Subject: #19019 [NEW]: exec doesnt accept abs paths
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17441@lists.php.net to get a copy of this message
From: rehman@rehman.ch Operating system: Windows PHP version: 4.2.2 PHP Bug Type: *General Issues Bug description: exec doesnt accept abs paths I run php CGI 4.2.2 on two servers with IIS on one everything is fine, on the hosting server the exec command cant find any absolute filepath, exec("sample.exe"); works exec("c:\\inetpub\\wwwroot\\sample.exe"); fails without giving error messages! on a third server it says "unable to fork" I've tried a lot, the php.ini possible restriction settings are not involved I checked and since it is twice the same file, and in one case it works. It must be some difference in the Server configuration. It also can't be the security settings as documented since the same file is once allowed once denied. Im lost in this, does someone know about such problems? how to proceed to find the problem source? -- Edit bug report at http://bugs.php.net/?id=19019&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=19019&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=19019&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=19019&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=19019&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=19019&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=19019&r=support Expected behavior: http://bugs.php.net/fix.php?id=19019&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=19019&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=19019&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=19019&r=globals

« previous php.bugs (#17441) next »