#19019 [Opn]: exec doesnt accept abs paths

From: Date: Wed, 21 Aug 2002 15:58:51 +0000
Subject: #19019 [Opn]: exec doesnt accept abs paths
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17461@lists.php.net to get a copy of this message
ID: 19019 User updated by: rehman@rehman.ch Reported By: rehman@rehman.ch Status: Open Bug Type: *General Issues Operating System: Windows PHP Version: 4.2.2 New Comment: I found out: exec using absolut paths seems to need rights not only on the file executed but on the whole path tree leading to it, which is not allways allowed by the hosters!!! I run php CGI 4.2.2 on two servers with IIS on one everything is fine, on the hosting server the exec command cant find any absolute filepath, exec("sample.exe"); works exec("c:\\inetpub\\wwwroot\\sample.exe"); fails without giving error messages! on a third server it says "unable to fork" I've tried a lot, the php.ini possible restriction settings are not involved I checked and since it is twice the same file, and in one case it works. It must be some difference in the Server configuration. It also can't be the security settings as documented since the same file is once allowed once denied. Im lost in this, does someone know about such problems? how to proceed to find the problem source? Previous Comments: ------------------------------------------------------------------------ [2002-08-21 09:41:19] rehman@rehman.ch I run php CGI 4.2.2 on two servers with IIS on one everything is fine, on the hosting server the exec command cant find any absolute filepath, exec("sample.exe"); works exec("c:\\inetpub\\wwwroot\\sample.exe"); fails without giving error messages! on a third server it says "unable to fork" I've tried a lot, the php.ini possible restriction settings are not involved I checked and since it is twice the same file, and in one case it works. It must be some difference in the Server configuration. It also can't be the security settings as documented since the same file is once allowed once denied. Im lost in this, does someone know about such problems? how to proceed to find the problem source? ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19019&edit=1

« previous php.bugs (#17461) next »