Bug #64965 [Opn->Nab]: phpmyadmin doesn't start - error php

From: Date: Mon, 03 Jun 2013 18:39:12 +0000
Subject: Bug #64965 [Opn->Nab]: phpmyadmin doesn't start - error php
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-179308@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=64965&edit=1 ID: 64965 Updated by: pajoye@php.net Reported by: marcelo dot pontarelli at vodafone dot it Summary: phpmyadmin doesn't start - error php -Status: Open +Status: Not a bug Type: Bug Package: Reproducible crash Operating System: windows xp sp2 PHP Version: 5.4.15 Block user comment: N Private report: N New Comment: Enable the mbstring extension in your php.ini and this error will disappear. Please use the php-install, php-general or php-windows mailing list for further support questions. Previous Comments: ------------------------------------------------------------------------ [2013-06-03 18:28:59] marcelo dot pontarelli at vodafone dot it Description: ------------ Trying to launch phpmyadmin from XAMPP: Fatal error: Call to undefined function mb_detect_encoding() in C:\xampp\phpMyAdmin\libraries\php-gettext\gettext.inc on line 177 --- part affected ---- * Convert the given string to the encoding set by bind_textdomain_codeset. */ function _encode($text) { $source_encoding = mb_detect_encoding($text); $target_encoding = _get_codeset(); if ($source_encoding != $target_encoding) { return mb_convert_encoding($text, $target_encoding, $source_encoding); } else { return $text; } } ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=64965&edit=1

« previous php.bugs (#179308) next »