Bug #65100 [Com]: Reject root run
Edit report at https://bugs.php.net/bug.php?id=65100&edit=1
ID: 65100
Comment by: dlsniper@php.net
Reported by: admin at mvpro dot net
Summary: Reject root run
Status: Assigned
Type: Bug
Package: FPM related
Operating System: Linux Debian Wheezy
PHP Version: 5.5.0
Assigned To: fat
Block user comment: N
Private report: N
New Comment:
Hi,
I'm using Ubuntu 13.04 and I've compiled PHP 5.5 with FPM from sources.
I do indeed get something like this:
[24-Jun-2013 18:09:32] ERROR: [pool default] please specify user and group other than root
[24-Jun-2013 18:09:32] ERROR: FPM initialization failed
but I don't think it is a bad thing.
Running PHP with root as user would be considered a major security issue so maybe it's not
really a bug.
Can you provide a real use case where you'd want to allow a script executed via FPM to have
root privileges as I can't think of a good one right now?
Thanks.
Previous Comments:
------------------------------------------------------------------------
[2013-06-23 03:36:07] admin at mvpro dot net
Description:
------------
Php5-fpm rejected to run with user 'root' and group 'root', it fails to load.
While proccess priority was implemented, i assume, running PHP-fpm with user
'root' should be allowed.
Test script:
---------------
Put in /etc/php5/fpm/pool.d/www.conf
user = root
Expected result:
----------------
Success run.
Actual result:
--------------
Fail to run.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=65100&edit=1
Thread (8 messages)