Bug #66482 [NEW]: unknown entry 'priority' in php-fpm.conf
| From: | itxx00 at gmail dot com | Date: | Tue, 14 Jan 2014 02:33:58 +0000 |
| Subject: | Bug #66482 [NEW]: unknown entry 'priority' in php-fpm.conf | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-183779@lists.php.net to get a copy of this message | ||
From: itxx00 at gmail dot com
Operating system: CentOS6.4 x64
PHP version: 5.4.24
Package: FPM related
Bug Type: Bug
Bug description:unknown entry 'priority' in php-fpm.conf
Description:
------------
In php-fpm.conf pool definition, set the priority with a value:
1.add a poll definition in php-fpm.conf:
[TESTPOOL]
;prefix = /path/to/pools/$pool
user = www
group = www
listen = /dev/shm/TESTPOOL.sock
listen.backlog = 65535
listen.owner = daemon
listen.group = daemon
listen.mode = 0600
priority = -19
pm = ondemand
pm.max_children = 10
2.restart php-fpm:
service php-fpm restart
will cause php-fpm init fail.
Expected result:
----------------
php-fpm can restart successfully.
Actual result:
--------------
/etc/init.d/php-fpm restart
Gracefully shutting down php-fpm warning, no pid file found - php-fpm is
not running ?
Starting php-fpm [14-Jan-2014 10:27:51] ERROR:
[/php54/etc/pool/testpool.conf:10] unknown entry 'priority'
[14-Jan-2014 10:27:51] ERROR: Unable to include
/php54/etc/pool/testpool.conf from /php54/etc/php-fpm.conf at line 10
[14-Jan-2014 10:27:51] ERROR: failed to load configuration file
'/php54/etc/php-fpm.conf'
[14-Jan-2014 10:27:51] ERROR: FPM initialization failed
failed
--
Edit bug report at https://bugs.php.net/bug.php?id=66482&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=66482&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=66482&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=66482&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=66482&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=66482&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=66482&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=66482&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=66482&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=66482&r=support
Expected behavior: https://bugs.php.net/fix.php?id=66482&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=66482&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=66482&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=66482&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=66482&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=66482&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=66482&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=66482&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=66482&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=66482&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=66482&r=mysqlcfg