Bug #66482 [Opn->Csd]: unknown entry 'priority' in php-fpm.conf
| From: | stas@php.net | Date: | Mon, 14 Apr 2014 00:33:21 +0000 |
| Subject: | Bug #66482 [Opn->Csd]: unknown entry 'priority' in php-fpm.conf | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-185230@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=66482&edit=1
ID: 66482
Updated by: stas@php.net
Reported by: itxx00 at gmail dot com
Summary: unknown entry 'priority' in php-fpm.conf
-Status: Open
+Status: Closed
Type: Bug
Package: FPM related
Operating System: CentOS6.4 x64
PHP Version: 5.4.24
Block user comment: N
Private report: N
New Comment:
Automatic comment on behalf of itxx00@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=636adf251c80884c151cb233bbdae1497fdadc4a
Log: Fix bug #66482, replace wrong item name 'priority' with 'process.priority'
in php-fpm.conf
Previous Comments:
------------------------------------------------------------------------
[2014-01-14 02:33:57] itxx00 at gmail dot com
Description:
------------
In php-fpm.conf pool definition, set the priority with a value:
1.add a poll definition in php-fpm.conf:
[TESTPOOL]
;prefix = /path/to/pools/$pool
user = www
group = www
listen = /dev/shm/TESTPOOL.sock
listen.backlog = 65535
listen.owner = daemon
listen.group = daemon
listen.mode = 0600
priority = -19
pm = ondemand
pm.max_children = 10
2.restart php-fpm:
service php-fpm restart
will cause php-fpm init fail.
Expected result:
----------------
php-fpm can restart successfully.
Actual result:
--------------
/etc/init.d/php-fpm restart
Gracefully shutting down php-fpm warning, no pid file found - php-fpm is not running ?
Starting php-fpm [14-Jan-2014 10:27:51] ERROR: [/php54/etc/pool/testpool.conf:10] unknown entry
'priority'
[14-Jan-2014 10:27:51] ERROR: Unable to include /php54/etc/pool/testpool.conf from
/php54/etc/php-fpm.conf at line 10
[14-Jan-2014 10:27:51] ERROR: failed to load configuration file '/php54/etc/php-fpm.conf'
[14-Jan-2014 10:27:51] ERROR: FPM initialization failed
failed
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=66482&edit=1