#19232 [Opn->Csd]: When Load apache I get libphp4.so: symbol __cmpdi2: referenced symbol not found

From: Date: Wed, 04 Sep 2002 18:11:50 +0000
Subject: #19232 [Opn->Csd]: When Load apache I get libphp4.so: symbol __cmpdi2: referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18446@lists.php.net to get a copy of this message
ID: 19232 Updated by: sniper@php.net Reported By: tbelote@mac.com -Status: Open +Status: Closed Bug Type: *Configuration Issues Operating System: Solaris 8 Sparc PHP Version: 4.2.2 New Comment: Just add --enable-libgcc to your configure line and it should be okay. (this bug is fixed in CVS) Previous Comments: ------------------------------------------------------------------------ [2002-09-04 13:04:15] tbelote@mac.com I configured PHP by running: ./configure --prefix=/usr/local/php-4.2.2 --with-mysql=/ usr/local/mysql --with-apxs=/usr/local/apache_1.3.26/bin/ apxs I have also tried --with-pic PHP was compiled using gcc 2.95.3. I am trying to use it as a shared module with apache 1.3.26 + mod_perl and mod_ssl. When I run apachectl I get: # ./apachectl start Syntax error on line 236 of /usr/local/apache_1.3.26/conf/ httpd.conf: Cannot load /usr/local/apache_1.3.26/libexec/libphp4.so into server: ld.so.1: /usr/local/apache_1.3.26/bin/httpd: fatal: relocation error: file /usr/local/apache_1.3.26/ libexec/libphp4.so: symbol __cmpdi2: referenced symbol not found ./apachectl start: httpd could not be started ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19232&edit=1

« previous php.bugs (#18446) next »