#19232 [Csd]: When Load apache I get libphp4.so: symbol __cmpdi2: referenced symbol not found
| From: | tbelote at mac dot com | Date: | Wed, 04 Sep 2002 18:24:08 +0000 |
| Subject: | #19232 [Csd]: When Load apache I get libphp4.so: symbol __cmpdi2: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18448@lists.php.net to get a copy of this message | ||
ID: 19232
User updated by: tbelote@mac.com
Reported By: tbelote@mac.com
Status: Closed
Bug Type: *Configuration Issues
Operating System: Solaris 8 Sparc
PHP Version: 4.2.2
New Comment:
thanks that worked perfectly.
Previous Comments:
------------------------------------------------------------------------
[2002-09-04 13:11:50] sniper@php.net
Just add --enable-libgcc to your configure line and it should be okay.
(this bug is fixed in CVS)
------------------------------------------------------------------------
[2002-09-04 13:04:15] tbelote@mac.com
I configured PHP by running:
./configure --prefix=/usr/local/php-4.2.2 --with-mysql=/
usr/local/mysql --with-apxs=/usr/local/apache_1.3.26/bin/
apxs
I have also tried --with-pic
PHP was compiled using gcc 2.95.3. I am trying to use it as
a shared module with apache 1.3.26 + mod_perl and mod_ssl.
When I run apachectl I get:
# ./apachectl start
Syntax error on line 236 of /usr/local/apache_1.3.26/conf/
httpd.conf:
Cannot load /usr/local/apache_1.3.26/libexec/libphp4.so
into server: ld.so.1: /usr/local/apache_1.3.26/bin/httpd:
fatal: relocation error: file /usr/local/apache_1.3.26/
libexec/libphp4.so: symbol __cmpdi2: referenced symbol not
found
./apachectl start: httpd could not be started
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19232&edit=1