#16967 [Com]: FATAL: emalloc(): Unable to allocate
| From: | arnout at argeweb dot nl | Date: | Thu, 05 Sep 2002 12:00:48 +0000 |
| Subject: | #16967 [Com]: FATAL: emalloc(): Unable to allocate | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18484@lists.php.net to get a copy of this message | ||
ID: 16967
Comment by: arnout@argeweb.nl
Reported By: info@i-plaats.nl
Status: No Feedback
Bug Type: Unknown/Other Function
Operating System: Redhat Linux 7.2 (Intel)
PHP Version: 4.2.0
New Comment:
I'm having the same problem with serveral scripts.
I'm not getting any 404s. The output to the browser just stops in the
middle of a script without any warnings or errors, and the error_log
says:
FATAL: emalloc(): Unable to allocate -458296 bytes
FATAL: emalloc(): Unable to allocate -417336 bytes
FATAL: emalloc(): Unable to allocate -459576 bytes
FATAL: emalloc(): Unable to allocate -417336 bytes
FATAL: emalloc(): Unable to allocate -418616 bytes
My version:
PHP 4.2.2
Apache/1.3.26
Mysql 3.23.52
Redhat 7.2
Zend Engine v1.2.0
'./configure' '--with-mysql=/usr/local/mysql' '--enable-versioning'
'--enable-track-vars=yes' '--enable-url-includes'
'--enable-sysvshm=yes' '--enable-sysvsem=yes' '--enable-magic-quotes'
'--with-system-regex' '--with-zlib' '--with-pdflib=/usr/local'
'--with-xml' '--with-iconv=/usr/local' '--enable-ftp'
'--with-imap'
'--with-pdflib=/usr/local' '--with-gd=/usr'
'--with-freetype-dir=/usr/local' '--enable-gd-native-ttf'
'--enable-gd-imgstrttf' '--with-jpeg-dir=/usr' '--with-png-dir=/usr'
'--with-swf=/usr/local/src/libswf/dist/' '--with-ming'
'--with-xslt-sablot=/usr/local' '--enable-xslt' '--with-imagick'
'--with-apxs=/usr/local/apache/bin/apxs'
Previous Comments:
------------------------------------------------------------------------
[2002-06-04 01:00:06] php-bugs@lists.php.net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2002-05-12 09:42:09] eodabas@progen.com.tr
I have the same problem with php 4.2.0, Redhat 7.2, apache 1.3.22
(mod_perl/1.26 mod_throttle/2.11 PHP/4.2.0 FrontPage/4.0.4.3
mod_ssl/2.8.5 OpenSSL/0.9.6b).
here is the configuration line
./configure --with-apxs=/usr/local/psa/apache/bin/apxs\
--enable-calendar\
--enable-track-vars\
--enable-ftp\
--enable-exif\
--disable-debug\
--enable-pear\
--with-system-regex\
--with-pcre\
--with-imap\
--with-mod_charset\
--without-imap-ssl\
--with-openssl\
--with-config-file-path=/usr/local/psa/apache/conf\
--with-swf=/usr/local\
--with-mysql=/usr/local/psa/mysql\
--with-mcrypt=/usr/local\
--with-curl-dir=/usr/local/include/curl\
--with-java\
--with-zip=/usr/local\
--with-dom=/usr/local\
--with-tiff-dir=/home/admin/apache/tiff-v3.5.7\
--with-gd=/home/admin/apache/gd-2.0.1\
--enable-gd-native-ttf\
--enable-gd-imgstrttf\
--with-jpeg-dir=/usr/local\
--with-gif-dir=/usr/local\
--with-zlib-dir=shared\
--with-png-dir=/usr/local\
--with-freetype-dir=/home/admin/apache/freetype-2.0.6/\
regards
------------------------------------------------------------------------
[2002-05-04 00:22:52] yohgaki@php.net
Oops, you've down graded PHP.
Could you try snapshot see if problem is still there or not?
http://snaps.php.net/
------------------------------------------------------------------------
[2002-05-04 00:16:25] yohgaki@php.net
Strange. Make this report bogus.
------------------------------------------------------------------------
[2002-05-03 09:31:33] info@i-plaats.nl
I have reinstalled my hole system, with all software but php version
4.1.2 instead of 4.2.0 and it works!
I have no idea what the problem was but it is gone :)
Thanx everyone !!
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/16967
--
Edit this bug report at http://bugs.php.net/?id=16967&edit=1