#19249 [NEW]: pdflib binary distribution, php and mac os X 10.2

From: Date: Thu, 05 Sep 2002 12:55:21 +0000
Subject: #19249 [NEW]: pdflib binary distribution, php and mac os X 10.2
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18487@lists.php.net to get a copy of this message
From: jm.bernadet@wanadoo.fr Operating system: unix (mac os x 10.2) PHP version: 4CVS-2002-09-05 PHP Bug Type: PDF related Bug description: pdflib binary distribution, php and mac os X 10.2 hello all Thanks for creating and maintaining such a powerful language ! and it has so much useful exensions... I use it with mysql and pdflib on a full-time basis to migrate a commercial/document database management software previously made under Visual dBase 5.5+Word 95. God users, developers (me) and admins (me again) they do like client/server - thin client based software after years of ms-windows pain !!! here's the problem : php 4.3.0-dev (got it by anonymous CVS on september 5) compiles and loads fine into apache 1.3.26 (rebuilt from source, not Apple’s) on my MacOS X 10.2 box until i add pdflib support using the pdflib binary distribution for my machine (the only distribution that includes the PDF import feature). I can build the module but it won't load into apache ("Reason unknown"). here's my configure line : ./configure --with-mysql --with-apxs --with-zlib --with-pdflib=../pdflib-4.0.3-MacOSX/bind/c here are the last steps and errors after make : [quicksilver:~/php4] jeanmari# cp libs/libphp4.so /usr/libexec/httpd [quicksilver:~/php4] jeanmari# apachectl stop /usr/sbin/apachectl stop: httpd stopped [quicksilver:~/php4] jeanmari# apachectl start Syntax error on line 239 of /etc/httpd/httpd.conf: Cannot load /usr/libexec/httpd/libphp4.so into server: (reason unknown) /usr/sbin/apachectl start: httpd could not be started [quicksilver:~/php4] jeanmari# note that i have the same problem with the other php version that can be built on mac os x 10.2 (that is php 4.1.0 with a modified libtool from 4.0.6) please help !!! -- Edit bug report at http://bugs.php.net/?id=19249&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=19249&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=19249&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=19249&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=19249&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=19249&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=19249&r=support Expected behavior: http://bugs.php.net/fix.php?id=19249&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=19249&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=19249&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=19249&r=globals

« previous php.bugs (#18487) next »