#19249 [Opn->Fbk]: pdflib binary distribution, php and mac os X 10.2
| From: | kalowsky@php.net | Date: | Thu, 05 Sep 2002 13:18:49 +0000 |
| Subject: | #19249 [Opn->Fbk]: pdflib binary distribution, php and mac os X 10.2 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18489@lists.php.net to get a copy of this message | ||
ID: 19249
Updated by: kalowsky@php.net
Reported By: jm.bernadet@wanadoo.fr
-Status: Open
+Status: Feedback
Bug Type: PDF related
Operating System: unix (mac os x 10.2)
PHP Version: 4CVS-2002-09-05
New Comment:
Hrm there have been reports that pdflib is working. In fact I think I
had it working on 10.1 before 10.2 blew away all my installed files.
First off have you tried to build a custom version of the pdflib?
Second where did you get this copy of pdflib so that I can try using it
as well.
Previous Comments:
------------------------------------------------------------------------
[2002-09-05 07:55:21] jm.bernadet@wanadoo.fr
hello all
Thanks for creating and maintaining such a powerful
language ! and it has so much useful exensions... I use it
with mysql and pdflib on a full-time basis to migrate a
commercial/document database management software previously
made under Visual dBase 5.5+Word 95. God users, developers
(me) and admins (me again) they do like client/server -
thin client based software after years of ms-windows pain
!!!
here's the problem :
php 4.3.0-dev (got it by anonymous CVS on september 5)
compiles and loads fine into apache 1.3.26 (rebuilt from
source, not Apples) on my MacOS X 10.2 box until i add
pdflib support using the pdflib binary distribution for my
machine (the only distribution that includes the PDF import
feature). I can build the module but it won't load into
apache ("Reason unknown").
here's my configure line :
./configure --with-mysql --with-apxs --with-zlib
--with-pdflib=../pdflib-4.0.3-MacOSX/bind/c
here are the last steps and errors after make :
[quicksilver:~/php4] jeanmari# cp libs/libphp4.so
/usr/libexec/httpd
[quicksilver:~/php4] jeanmari# apachectl stop
/usr/sbin/apachectl stop: httpd stopped
[quicksilver:~/php4] jeanmari# apachectl start
Syntax error on line 239 of /etc/httpd/httpd.conf:
Cannot load /usr/libexec/httpd/libphp4.so into server:
(reason unknown)
/usr/sbin/apachectl start: httpd could not be started
[quicksilver:~/php4] jeanmari#
note that i have the same problem with the other php
version that can be built on mac os x 10.2 (that is php
4.1.0 with a modified libtool from 4.0.6)
please help !!!
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19249&edit=1