Bug #66557 [Com]: modules/libphp5.so: symbol unixd_config: referenced symbol not found
Edit report at https://bugs.php.net/bug.php?id=66557&edit=1
ID: 66557
Comment by: zaqdev84 at gmail dot com
Reported by: iand at ekit-inc dot com
Summary: modules/libphp5.so: symbol unixd_config: referenced
symbol not found
Status: Open
Type: Bug
Package: Reproducible crash
Operating System: Solaris 9
PHP Version: 5.5.8
Block user comment: N
Private report: N
New Comment:
Any chances of this bug being fixed in any future releases?
Previous Comments:
------------------------------------------------------------------------
[2014-01-23 00:24:51] iand at ekit-inc dot com
Description:
------------
Compiled Apache 2.4.6 with php 5.5.8; builds ok but at run time,
php load fails with this:
httpd: Syntax error on line 56 of /opt/local/apache/conf/httpd.conf: Cannot load
modules/libphp5.so into server: ld.so.1: /opt/local/apache/bin/httpd: fatal: relocation error: file
/opt/local/apache/modules/libphp5.so: symbol unixd_config: referenced symbol not found
This is because sapi/apache2handler/php_functions.c tests
for the new name for unixd_config (ap_unixd_config) using a check
on MODULE_MAGIC_NUMBER_MAJOR but it doesn't include the header file
that includes that definition.
Fix is trivial: include ap_mmn.h
Seems lots of people have reported this on various OS's but a search
of the bug repo for unixd_config doesn't show anything.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=66557&edit=1
Thread (5 messages)